Respeaker 6-mic array - can't install

Hi,

I have a problem with the intallation of seeed-voicecard.
When I execute “sudo ./install.sh”, I have this :

pi@raspberrypi:~/Respeaker/seeed-voicecard $ sudo ./install.sh

will compile with the latest kernel…
Atteint :1 http://raspbian.raspberrypi.org/raspbian buster InRelease
Atteint :2 http://archive.raspberrypi.org/debian buster InRelease
Lecture des listes de paquets… Fait
Construction de l’arbre des dépendances
Lecture des informations d’état… Fait
Tous les paquets sont à jour.
Lecture des listes de paquets… Fait
Construction de l’arbre des dépendances
Lecture des informations d’état… Fait
dkms est déjà la version la plus récente (2.6.1-4).
git est déjà la version la plus récente (1:2.20.1-2+deb10u3).
i2c-tools est déjà la version la plus récente (4.1-1).
libasound2-plugins est déjà la version la plus récente (1.1.8-1).
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
alsa-base gstreamer0.10-alsa gstreamer0.10-plugins-base libdrm-etnaviv1
libgstreamer-plugins-base0.10-0 libgstreamer0.10-0 libllvm6.0 libmicrodns0
libva-wayland2 libxfce4util-bin libxfce4util-common libxfce4util7
libxfconf-0-2 pimixer point-rpi python3-pyperclip python3-thonny xfconf
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
Lecture des listes de paquets… Fait
Construction de l’arbre des dépendances
Lecture des informations d’état… Fait
raspberrypi-kernel est déjà la version la plus récente (1.20200717-1).
raspberrypi-kernel-headers est déjà la version la plus récente (1.20200717-1).
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
alsa-base gstreamer0.10-alsa gstreamer0.10-plugins-base libdrm-etnaviv1
libgstreamer-plugins-base0.10-0 libgstreamer0.10-0 libllvm6.0 libmicrodns0
libva-wayland2 libxfce4util-bin libxfce4util-common libxfce4util7
libxfconf-0-2 pimixer point-rpi python3-pyperclip python3-thonny xfconf
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
W: --force-yes est obsolète, veuillez plutôt utiliser l’une des options commençant par --allow.


Deleting module version: 0.3
completely from the DKMS tree.

Done.

Creating symlink /var/lib/dkms/seeed-voicecard/0.3/source ->
/usr/src/seeed-voicecard-0.3

DKMS: add completed.

Kernel preparation unnecessary for this kernel. Skipping…

Building module:
cleaning build area…
make -j4 KERNELRELEASE=5.4.51+ -C /lib/modules/5.4.51+/build M=/var/lib/dkms/seeed-voicecard/0.3/build…(bad exit status: 2)
Error! Bad return status for module build on kernel: 5.4.51+ (armv7l)
Consult /var/lib/dkms/seeed-voicecard/0.3/build/make.log for more information.
can not compile with this kernel, abort
please try compile with the option --compat-kernel

If anyone has the solution, thank you in advance.

M.

Hi,
I have the same problem with 4-mic array.
After upgrading rpi, respeaker stopped working.
When reinstalling i receive an error that says:
can not compile with this kernel, abort

Help please.
My voice assistant stopped working.

Same to me,

cant install 4-mic array on debian buster

There are solutions in this issue.

The solution was given is this:

rm -R seeed-voicecard/
git clone https://github.com/HinTak/seeed-voicecard.git
cd seeed-voicecard
sudo ./install.sh

The problem is that each time I do apt upgrade kernel headers are updated and respeaker disappears from arecord list :frowning:

I have the same problem with you ,
Is there any official staff in the forum ? The solution given is invalid. When can you solve the problem that Respeaker 6-mic array cannot be installed

I’m in the same boat. I’m also frustrated by the “solution” proposed which downgrades the kernel to a nearly year-old kernel. That’s not a solution, it’s a security concern.

I bought the ReSpeaker 6-mic array because it seemed to be mostly plug-and-play, but I feel a return of the product is imminent.

I agree with you, the latest kernel support, we are still in development.We take the safety of our users very seriously.

Good to hear @Baozhu. Any ETA for the fixed version working on the current buster release?

To tell you the truth, we have plans to support it, but we haven’t started yet.The main thing is that the new RPI kernel is still in the BATA phase and has too many issues.We need the community to go through a period of testing. sudo ./install.sh --compat-kernel is still available. @gijs.mos