reServer - Firmware_Software

Setting up my new reServer and there is an updated firmware available online which is ODYSSEY-TGL-A_v2.0a dated 07/07/2022. The SHA256 HASH posted online is not matching to the file I have downloaded. I downloaded 2x and used 2 different tools to HASH check (7Zip and ComputeHash). Can someone double check the HASH they are getting against what is published on: Upgrading BIOS and Installing Drivers - Seeed Wiki


I’ve ran into the same issue. I’ve checked the SHA256 on both linux and mac. Nothing matches what is on the download page. I also checked the sha256 of the files inside the zip. Still not matching up. Please advise on how to verify downloaded files with supplied SHA256



“shasum -b -a 256
02cc2c24e615ee2665cccf79257709433d69c5b80326fb6db12d0341dac2e5f5 *”

openssl dgst -sha256
SHA256( 02cc2c24e615ee2665cccf79257709433d69c5b80326fb6db12d0341dac2e5f5

DOWNLOAD PAGE for reServer Bios

  • SHA256: 58971f80fa26b35bc205baeabacf7b9b262a6075f6b3fbb689af3557ac97f8f7

Hello Mattamus, what I discovered is the HASH published on seeedStudio website is for an older version of firmware “ODYSSEY-TGL-A_v1.7a.bin” and not what is available for download. Clearly, they have not updated the HASH information on their web site which is very sad. I took a risk and downloaded what was available and appears to be still the same version when I originally posted and proceeded with flashing my device. Everything went fine. I use this little guy as a pfsense Router for my network and all is fine, very stable no issues. Below is what pfsense shows on the system information page on the main dashboard

Vendor: American Megatrends International, LLC.
Version: ODYSSEY-TGL-A_v2.0a
Release Date: Thu May 19 2022

Hey Radman, thanks for the info. I’m disappointed they haven’t updated the hash as well. The reServer has so much potential. I plan on using it as a Frigate NVR with a Coral dual TPU. The reComputer just didn’t have enough horse power to handle all the cameras I run. The reServer seems like the perfect platform for a fpsense router as well. I’m currently running pfsense on a qotom i3 from 2017. Still works! Might upgrade depending on my experience with this NVR project. Anyways thanks again.