Rephone doesn't see sim card

Last week a friend gave me a rephone kit. A wonderful present! I assembled it and all things look if they’re working. I inserted a new sim card, but it doesn’t recognize it. It keeps saying sim missing. I tried a sim card of an other cell phone and it worked neither. The new sim card worked properly in the other cell phone. May be it has something to do with the network, however the provider is still keeping up the 2G network.
Please, can someone help me with this problem?

Hi Marten,

Thanks for the feedback.

I am thinking about:

CASE A - it could be a bad connection between the SIM card and the card slot here in your case.
CASE B - Every time you re-insert the SIM card, you need to reboot the RePhone

Could you please try the following:
Case A:

  1. Please check the direction of your SIM card, see if you have inserted it other way around
  2. Try to gently push in the card a little bit
  3. If your RePhone still shows “NO SIM” on the screen, use a tweezer to SLIGHTLY lever up the metal connector on the SIM card slot , DO NOT BE TO HARD OR YOU MAY BREAK IT.

Case B:
Turn off the rephone, re-insert the SIM card, then turn it on again to see if it works.

Please let us know if the problem is solved.
Thank you!


Hi ya

Thanks for answering my question. I tried both suggestions (rebooting after reinserting the sim card and bending the connections a little), but unfortunately neither worked. Could it be the connection with the network?

Hi Marten,

Do you mind tell me which country you are? And which mobile operator you were using? BTW you’ve mentioned about your it’s a present from your friend, did your friend get it from the kickstarter? Or it is a development sample we’ve given out?

It would be wonderful if you can upload a clear image of your RePhone here.


Hi Chao,
Thank you for answering so quickly!
I am from the Netherlands and I use the KPN network. The rephone is from kickstarter.
Here is a link to an image of my rephone: … e.jpg?dl=0

Regards, Marten

Hi Marten,

thanks for the details, our engineers are now looking into this problem. We will respond ASAP.
Once again thank you for your patience.


I had a similar issue as well when I first opened my phone, I resolved it by altering the seating of the SIM card. Basically, push it all the way in, then push it back out just a millimeter or two. After doing this and rebooting I had working network connectivity. Good luck!

Thanks Alden for the kind help.

Actually I am thinking the same issue here, maybe try to push it back out a little bit and then reboot to see how it goes. Cause as I can see from the image, all connections are good, except that the SIM card was pushed inside a bit too much.

Hi Marten,

Thanks for your reply, I’m the developer of Rephone, could you try to find other SIM of Vodafone or T-Mobile and try it again? ( the other operators in Netherlands )
Please let us know the result you try, it’s very helpful for us to solve this problem.

Thank you!
Once again thank you for your patience.


I have got the same problem with the KPN network.

Hi, bobbiy

 Have you ever tried the SIM of other operators ?

Not sure that this helps but i noticed that if you have a PIN set in your sim then the API will return “No SIM (0)”. Disabling the pin fixed it for me even with a Sim that was expired.

Hi Chao,
As suggested by blkhawki, I changed the setting of the sim-card with an other cellphone so that is doesn’t ask for a pin anymore. And now it works!
Thank you for all the help!

Regards, Marten

It is working now! Thanks a lot!

I have the same problem, the SIM card can’t be detected. Bending the pins a little bit changed nothing.
The sim card works fine in my Samsung Galaxy S3 Smartphone.

The function

VMINT number_count = 0;
number_count = vm_gsm_sim_get_card_count();

returns the value “-103”.

Which I think it means:

#define VM_SYMBOL_NOT_FOUND (-103)
/* The error code (-103) means a symbol cannot be found in the firmware. */

The function vm_gsm_sim_has_card(); returns the value “0”.

I’m using a sim card from “”, it’s a provider that uses the t-mobile network.

Hi kaktus,

have you tried disable the PIN as blkhawk suggested above?

Yes, I have disabled the pin in the SIM card with my smartphone…

Well, you seem to have run in a problem I have as well. Some of the API calls that are defined in the headers are not actually included in the Firmware blob. So you get the -103 code back.

As for why the congstar sim does not work - No idea, but I have an expired congstar sim that i just cut it down to nano-sim and put in the rephone module - the example arduino checksim sketch shows 1 for an active working sim.