Rephone doesn't see sim card

I figured it out… I always called the api from a sub thread, but some api’s can only be called from the main thread, my sim card is now detected correctly.

for me resolved
disable pin code in a smartphone
i have a german o2 prepaid

I had this same problem: The Xadow GSM+BLE module on my RePhone was not recognizing my Ting (USA) 2G Nano SIM. In the end, it was a seating problem with the FPC Cable. For anyone else struggling with this issue, you might try to re-seat your FPC Cable.

Also, this may just be coincidence, but:

  • I noticed that if the FPC Cable was not seated well on the Xadow Touchscreen module connector end, there was a problem with the Display.
  • I noticed that if the FPC Cable was not seated well on the Xadow GSM+BLE module connector end, there was a problem with the SIM card being recognized.

Hi, Christina
Thanks for your feeedback. About the second situation you describe “I noticed that if the FPC Cable was not seated well on the Xadow GSM+BLE module connector end, there was a problem with the SIM card being recognized”
Could you please post a picture when you meet this situation to us for figure out this problem?

I had the same problem. But I activated my sim on a phone and disabled the pin-code.
I had to wait until I got an text from the provider, that the sim was activated and after that everything worked on the rephone. I also have a HEMA sim-card. Hope this helps.
Because i’m also from the Netherlands now in Dutch:
Op een ouwe android de pincode beveiliging uitgezet en eerst iets doen zoals een sms-je sturen of zo en wachten tot je een sms-je ontvangt van de Hema dat je sim geactiveerd is. Daarna deed hij het.

Good Luck,


In regards to the SIM issue, can anyone tell me what carriers in the US has SIM cards that work in the RePhone?? I’m primarily looking for a SIM card from a prepaid, or no contract service. I am on Verizon and I just want to use this phone for experimentation purposes firstly.

Hallo from Germany, prepaid SIMCARD vodafone (CALLYA)
Test with 2x rephone and 2x simcard => no simcard.
I tried moving, gentel pushing etc… same result.
Tested SIMcard in smartfone working well…
please give some advise…

Same problem (no sim) :

After disabling the pin code in android the sim was recognized randomly.
After leveling up the metal connector the connection seems stable

Hi there,

Im using a DNA prepaid SIM card (Finland) and have the same issue: “no sim” found.
I disabled the PASSCODE with a iPhone…

can you guys help me?

Thanks in advance…


Could you please upload an image of your RePhone with SIM card inserted here, while your RePhone shows “NO SIM”?

Thank you.

My kit doesn’t work either. I’ve tried un-blocking the SIM and restarting Rephone several time and it still doesn’t work. Also, wtf is ‘levelling up the metal connector’? How hard would it be to add a picture or a video? I deeply regretted buying this kit. Not only it’s bad quality but there’s no proper customer service.

I was trying to get tech support help but when I try to enter the name of the product, it says ‘name not recognized’. Fuck my life, this is some shit customer service. I can’t even get technical support!!!

Just as hard as asking it politely. Because this needs hardware modification, no one will do it just to explain, no one would like to mess with working things.
Pull it with small tweezers until it bends A LITTLE up, so it needs a lasting deformation. I encountered this even with a Sony phone, so don’t be mad about it.

You can deal with this problem. There may be a problem with the phone. This is not accurate. Try using another sim card

Look at here. Perhaps you will find a solution to your problem.

Telia prepaid in Finland worked fine after disabling the PIN on another phone. It might have taken a long time to figure out without this forum.

Hey guys, I have the same problem I am from germany and my rephone kitdoesn´t found the sim card

I searched on every forum on internet and eventually end up fixing this by choosing network operator.