Problems installing Jetpack 5.0.2 to SSD on Jetson Xavier Sub MINI PC Black (A205)

Jetpack 5.0.2 support was recently released by Seeed Studio for the A205-based Jetson Xavier Sub MINI PC Black

This machine includes a 256 GB SSD attached to SATA ports on the board. However, I have not been able to install Jetpack 5.0.2 to this SSD using either the nVidia SDK Manager GUI or command line flashing tools.

I can flash to the internal eMMC memory without problem, and the Jetson will boot up and the SSD will be visible as a functional disk.

The SSD appears to be connected as a USB drive. If I try to flash using SDK Manager with the USB destination selected, it fails and reports that /dev/sda1 was not found.

If I flash using the command line approach instead, the host PC reports the operation was successful but when the Jetson boots up it gives an error indicating sda1 was not found.
$ sudo ./ jetson-xavier-nx-devkit-emmc sda1

Similar failure occurs if I try flashing using initrd instead.

Can you provide instructions on how to successfully install Jetpack 5.0.2 to the SSD on this machine please?

Experiencing the same issue! Have you solved it yet?

Not yet. Have posted to the nvidia forum and to the Seeed discord server, but no solutions yet. I’m confident a solution will be found though.

I am experiencing the same issue too! Has anyone solve this problem?
Why Seeed studio doesn’t answer?

Before flash the Jetson you have to change the repository/root of the eMMC to the SSD.
Here´s a link:

Sorry that link isn’t applicable. The drive is not an M.2 SSD.

I have exactly the same issue and I tried basically everything that internet suggest (from rootonnvme modifed to use sda1, to jetsonhacks different techniques, etc.) and there’s no way to make it work with jetpack 5.1 or jetpack 5.0.2.
I modified fstab, extlinuxconf as described in various nvidia forum messages, but the jetson stops during booting and enters a bash5 shell.
How to make use of 256GB SSD then? We cannot install all nvidia packages or other software we use on emmc.

I never found a solution. I pulled the Jetson board from this machine and put in in another box which had nvme support. The Sub Mini Black sits on my shelf as an expensive paperweight.

What box did you end up putting the Jetson in. I’m looking for 6 camera support + nvme.

Seeed Studio J202 carrier board and reComputer case. Only supports 2 cameras.