Problem connecting Wio Terminal CO2 Checker to Azure IoT

Hello Forum,

I’ve got a Wio Terminal CO2 Checker-Set for some experiments, and tried connecting it to Azure-IoT, as shown in the attached How-To links. Unfortunately regardless of what i try, its not possible to get a connection established. I followed all the steps and started over many times, but always the same result;

(The Display shows the following)

Connecting to SSID: network_iot
Sync time
Device provisioning:
Id scope =
Registration Id =
ERROR: RegisterDevice()

After this, the screen turns blank. Same behavior after a reset or cold-start.

I’ve checked the same Azure IoT Central Account with the IoT PnP App on my Smartphone, no problem connecting with this.

What am I doing wrong here?

The Problem is within the Documentation. The Pairing with Azure IoT only works with method “Azure IoT Hub DPS”, despite using Azure IoT Central in the Backend. Found no way getting it to work with the single “set_az_iotc” command. The Terminal only connects by using the three commands;

set_az_idscope IDSCOPE
set_az_regid REGID
set_az_symkey SYMKEY

Maybe the Documentation should be upgraded…

Here’s a tutorial on how to connect and send data from Wio Terminal to Qubitro if you’d be interested in the platform. The video is very detailed by the way. Hope it helps.

We’re working on a great IoT kit that will come with a full Azure connectivity tutorial and more Grove sensor support, so stay tuned!