OrinNX 16 & SeedStudio A603 Carrierboard Flash Error

As per the document provided by SeedStudio WiKi, I tried to flash OrinNX after installing NVMe 256G SSD on A603 carrier board.


A603 Carrier Board | Seeed Studio Wiki

A603 Carrier Board

I overwrote it with the driver for A603 provided by SeedStudio and proceeded with Flash with the command below.

sudo ./tools/kernel_flash/l4t_initrd_flash.sh --external-device nvme0n1p1 -c tools/kernel_flash/flash_l4t_external.xml -p “-c bootloader/t186ref/cfg/flash_t234_qspi.xml” --showlogs --network usb0 p3509-a02 +p3767-0000 internal

However, I get an error that says Return Value 4.
Error Log

Attached is the serial console log.
Serial Console Log

If i execute the above Flash command again without rebooting OrinNX,
A Return Value 8 error appears.
Flash Error Log

The serial console only shows the message below.

C> XUSBF: comp_code went out of sequence. Expected 1 insted of 223.

What could be the problem?

You may need to answer a few questions so that I can better solve your problem:

  1. Do you enter recovery mode by adding the jumper? If you did, send a photo of lsusb command.

  2. which jetpack version do you flashed?

  3. please make sure the micro-usb cable you are using supports data

  4. which version of Ubuntu do you use on your PC

  1. Connect the jumper to enter recovery mode.
    Below is the lsusb command output.

(base) hexafactory@hexafactory-1804:~$ lsusb
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 046d:c534 Logitech, Inc. Unifying Receiver
Bus 001 Device 006: ID 0955:7323 NVidia Corp.
Bus 001 Device 004: ID 8087:0026 Intel Corp.
Bus 001 Device 002: ID 067b:2303 Prolific Technology, Inc. PL2303 Serial Port
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

  1. The jetpack version uses 5.1.1.

  2. This is a micro-usb cable that supports four data.
    I’ve tried using a different cable and it’s the same.

  3. ubuntu 18.04 / intel
    (base) hexafactory@hexafactory-1804:~$ uname -a
    Linux hexafactory-1804 5.4.0-150-generic #167~18.04.1-Ubuntu SMP Wed May 24 00:51:42 UTC 2023 x86_64 x86_64 x86_64 GNU/Linux

I found that this problem is caused by the WiFi module (Intel) installed in the M.2 E port of the SeedStudio A603 Carrier board when flashing.

When flashing, do not install anything except NVMe SSD, and install M.2 e WiFi module after installation and booting is completed.

problem solving!