OLed Display on Seeeduino Xiao expansion board won't work

Hi Guys,

Just bought the Xiao and the Seeeduino Xiao expansion board.

I am not new to Arduino, so …

I added the Xiao to the ide, and installed the u8g2 library as instructed.

I tried both “Hello World” examples, both don’t work.

I tried the “Happy Birthday” for the buzzer, to see if the board worked at all…

That works, so the ide works, the Xiao works, the board works, only the OLed does not work.

Any ideas anybody?

Thanks in advance.

With kind regards,

Roland Slegers

1 Like

Seeed a little help please???

It is also a bit confusing that there are 2 example files: OLED_SSD1327_v1 and OLED_SH1107G_v2???

Which one is right??? I tried both, but please make sure that your stuff is working and deliver one file.

Together with the supplier (TinyTronics in Holland) we solved it. Not thanks to @Seeed they are very quite…

We found out that it is a documentation bug. The documentation mentions that you should install a library, and it gives a link to the page where you can install it, but if you click the button there another library is installed. The supplier told me they would contact @Seeed about this. It means you have to look very carefully at what libraries are mention and install them yourself from the GitHub.

Hey, What resolved the issue? Can you share some details please - I’m facing a similar issue

Nothing. Seeed won’t solve the issue. They don’t react. I am stuck with a bricked thing. I moved to the ESP32. Wonderful thing, never failed on me yet. Terrible support from Seeed.

1 Like

A follow up to this - looks like the board functions weirdly with M1 Mac Air. I fortunately tried it with a windows machine and the OLED display quickly got recognized and displayed time by default. I’m unsure if that’s the default view but it seems to be working.

Separately - the SWD spring pins on my board seem to be misaligned so debugging and reset options are unavailable. Perhaps SeeedStudio can improve their manufacturing process a bit further

In my humble opinion there is a lot that they can improve. They could/should take back the faulty Xiao’s and replace them with new working Xiao’s. They could/should respond to problems. I never ever saw any reaction from them what-so-ever. I moved away from them. The ESP32 works fine for me. I can highly recommend it, that’s a thing that will work.

1 Like