ODYSSEY - X86J4105864 Arduino ide port problem

Hi All
yesterday I tried add Seeeduino SAMD board libs and after finished
I choose the seeduino zero board but the port is grey ( no port list )
any solution? thank you

Hi @tkraspilabs,

I ran into the same issue. Find the solution in this post Odyssey x86j4105 ubuntu 20.4 no /dev/ttyACM0 and no seeeduino listed under lsusb . The issue is caused by v1.8 of the board library. You will likely need to reflash the bootloader and downgrade your library to 1.7.9.

Hi @CamRodandChief, thank you for your answer , I tried to reset the Arduino Core from Odyssey but how to know the reset is done because the port still grey color :-(.
next I will try the flashing the Arduino core and hope to solve the problem.

I have j-link and want to flashing the arduino core, but the problem is 5v from J-link and arduino core just 3v.
is it possible that i just plug in the swclk and swdio pins without the 5v and gnd pins of the j-link to arduino core ?
And other sources , I saw we can flash samd21 with raspberry pi under openocd, can we use it? thank you

Done, I tried to flash it with Raspberry Pi 3B and OpenOCD
I was able to recover the boards following the Adafruit Raspberry Pi openocd tutorial here, and some modification into raspberrypi2-native.cfg :

bcm2835gpio_swd_nums 25 24
bcm2835gpio_srst_num 18
reset_config srst_only srst_push_pull

For wiring from backside odyssey samd21 pin out :
Pi -GPIO Samd21
GND ---------------> GND ( I used top side gpio )
3V ------------------> 3V
24 -----------------> SWDIO
25 -----------------> SWCLK

the odyssey status is off when I flash it :wink:

For bootloader file for smad21 download from here, thank to @CamRodandChief :wink: