nRF52 NFC.h header file not found

I am trying to run an example code given here.
My goal is to be able to send simple message over NFC.
I have NFC antenna attached to XIAO nRF52840 Sense board. I followed the instructions here on how to load the libraries. However, the NFC.h file not found.
Here showing that libraries were installed

Any ideas on what can cause this error and how to solve it?


error I get

I’m having the same issue. Have you found a solution yet?

I haven’t. I achieved what I needed with passive NFC (tag) and will implement active solution later with Adafruit Feathers since it has interface to program it through Segger.

I have the same problem. I tried to install the NFC.h library from “ArduinoCore-primo-master”, but after compile, report another missing library “nfc_t2t_lib.h”.
I think that it isn’t the correct way to solve it.

I am having the same issues mentioned above. I either get the error that the NFC.h library cannot be found or that I have not declared NFC yet (when choosing the mbed-enabled board). I have also tried what @AD22 did and imported the NFC.h library from the Primo but this just has you importing missing libraries one after the other.
Has anyone found a solution yet?

Same here also. Anyone have NFC read+write working with Arduino IDE and the NRF52 based Seeed Sense?

It is almost half a year since the first posting,
Has anyone heard anything about the fix?