No Reply from SenseCAP s700 v2 in RS485 ASCII

Does this setting actually work? I’ve been able to get the weather station to rely with its address once out of 50 or more tries. I have tried an Arduino device with an rs485 converter and had no luck, I’ve also tried a terminal emulator using a rs485 to USB adapter and was able to get the device to reply with it’s address once but not again. It seems like no matter what I do I get crickets from this device on the other end. Is there something I’m missing or will I have to use modus RTU to communicate with this device?
RS232 is listed as another option but there is no documentation for how to connect to the device in this mode. The M8 connector only has ports for RS485 and SDI12 labelled. Is there more indepth documentation for this device somewhere that could help me solve these issues?



Hi there,
According to the V2 info it deleted the RS-232 interface capable,
The RS-485 hardware is faster BTW , modbus RTU is the protocol AFAIK.
I would use the RS-485 Is it half duplex(2 wire) or full duplex(4wire). with a PC and interface converted , You should be able to get data from it, But it matters what commands are sent for responses.
I don’t have one but RS-485 ascii to test is the way to go. IMO
GL :slight_smile: PJ

Section 4.1 does that picture show how you have it connected to Computers interface converter(rs-485)

I have the weather sensor connected to a RS485 to usb adapter as shown in the manual, I get no response 99% to the “?” command (should return the device address), any other command returns “0XA;…=#0” which is the command not recognised error. I guess they changed the protocol and haven’t updated the manual. Very frustrating as the ascii protocol in the manual seems good and simple to implement but modbus RTU is very complex.

Might be because the sensor is the V2 version and hasn’t been documented yet.

I guess the documentation was supposed to go here but hasn’t been uploaded.