No data from Grove sensor (BME280)

Hello everyone,

I recently acquired from Arduino.cc this Seeed sensor along with an Arduino MKRWiFi1010 and a MKR connector carrier to make the previous board compatible with the Grove connectors.

I’m new in this field, so I started with the most basic sketches from Arduino’s web site to understand how I could program the micro-controller (built-in LED and RGB LEDs) [1]. All of them worked well, so everything seems fine up to this point in the hardware.

I used the same approach to try your Grove BME280 sensor. I found and followed your guide [2]. The LED on the Arduino board blinked when uploading the program but I didn’t receive anything in the IDE serial monitor. Not even a single word. The only difference I can see between your guide and my trial is that you are using a Seeeduino board instead of an Arduino MKR one. I don’t know yet enough to discern whether this is relevant or not.

Therefore, I tried a tutorial in the Arduino web site [3] showing the use of my MKR board with this same sensor (BME280 with I2C connection) but without using a Grove connector. I couldn’t get any reading from the sensor either although, at least this time, I received some feedback through the IDE serial monitor about not being able to contact the sensor.

As far as I understand, the only and major change between both trials is the library to get in contact with the sensor. Moreover, the issue seems to be related with how the sensor is connected to the micro-controller. I couldn’t find anything relevant after a typical Google search. Browsing the .cpp and .h files of both libraries as well as the original firmware from the Bosch sensor for “any” evident discrepancy didn’t help either because it’s the first time I open and try to read C++ files. Obviously, I didn’t understand much.

Any other suggestion? The statement in your web site about Grove making prototyping even easier would suggest I’m even stupider than I thought. What I’m missing then? How could I improve my knowledge and make it work? Is this a simple bad parameter issue in any of the libraries? Is it the board? What do you think I should be looking?

Thank you in advance to anyone that would like to help.

[1] https://docs.arduino.cc/tutorials/mkr-wifi-1010/built-in-rgb
[2] https://wiki.seeedstudio.com/Grove-Barometer_Sensor-BME280/
[3] your system doesnt allow me to write more than 2 links so I’m leaving the 3rd one as text docs.arduino.cc/tutorials/mkr-wifi-1010/connecting-sensors#i2c

Hello again,

I’m writing again to tell you that there is nothing bad with your product and library. As I guessed initially, it was me and my lack of knowledge in this field.

I wrongly assumed that all the Grove connections in the MKR connection carrier were equivalent (all analog were equivalent, all digital were equivalent). I had already tried different Grove ports to connect the sensor, all gave the same outcome: nothing. Eventually, I discovered that only 1 of all the digital connectors in the carrier is wired to the MKR board according to the grove connector specifications.

I apologize for bothering you and anyone else. Thanks.