No audio output on Respeaker 2mic hat from the JST2.0 Out

I am using a Respeaker 2mic hat with raspberry zero w. When I used the “aplay music.wav” to play files, I can only get sound from the 3.5mm Audio Jack, but there is no sound from the speaker connected to the JST2.0 Speaker Out. I tried the “alsamixer” to set Param, but nothing changed. Is there a switch to open the channel of JST2.0 Speaker Out? The screen of the alsamixer is showed in the attachment.

Hi there,

there is no switch, plug the speaker to jst2.0 and aplay the wav files. you can hear the voice from speaker.

what kinds of speaker do you use?

you also can plug another usb cable to 2 mic pi hat mic micro-usb port to provide the sufficient power supply for speaker. thanks.

I had the same issue but found that I needed to increase the mixer setting for “Playback” in addition to the “Speaker” settings that you show:

[attachment=0]Screen Shot 2018-11-14 at 18.21.12.png[/attachment]

I’m using a 4ohm speaker and find that the settings I have (the left-most Speaker setting is the same as the Playback one) work well.
Screen Shot 2018-11-14 at 18.21.12.png

I have the same issue. In my case, adjusting alsamixer does not solve the problem. I see no signal from JST2.0 regardless of alsamixer setting. Headphone jack works fine though.

When I run </s>aplay -l<e> I see only 7 subdevices instead of 8. Does that matter? My kernel version is 20181112-1 and I saw no particular error during the installation nor during the boot.

Problem was solved after playing with alsamixer a bit and after one more boot. Now everything works as it should be