New Xiao bricked after a few days... :-(

Hi guys,

New xiao (just a few days old) already bricked while uploading a sketch…

In my humble opinion I did nothing wrong, just uploaded a sketch…

This never happened to me with a normal Arduino Uno V3.

@Seeed: What now? Can I return it? Your product does not work…

Please help…

Also, - I am disappointed.
My XIAO worked for 1 day.
Somehow my XIAO got bricked. It has just been my second day trying it out.
Just playing around with the Blink sketch. - nothing attached to XIAO.

The XIAO is definitely bricked:

  • It has solid Green LED
  • Reset pins, - no luck with any combination of presses or speed.
  • No USB Port found.

I can’t see how this could so easily happen to an otherwise good product.
I’ve worked with Microchip PIC for years and never had such disappointment.

To make matters worse, I already ordered 12 more XIAO for a future product.
But now, I have my doubts about continuing on with this model.

There should really be some statement from Seeed to address this issue
as many users seem to be experiencing the same problem.

@Martian Thanks for your response. I am sorry to see that you are also a victim of this.

The eerie silence coming from @Seeed does not predict something good. I personally can only say that I find the product below par, as goes for their support to solve the problem. The least they could and should do is issue a call-back program for bricked Xiao’s and re-issue a new one. Than solve the problem internally.

I never had this problem with a normal Arduino, like a Uno V3. I personally am thinking of moving back to the Uno V3 as this is a stable platform. I don’t need/want a thing that bricks for no apparent reason. That is not a platform that proves to be stable. I have serious doubts about the Xiao.

See Xiao bricked and not responding anymore - Products & Technology / XIAO - Seeed Forum (

If you have multiple Xiao boards, why not use one as SWD debugger to reflash the bricked ones?

Follow the full procedure from The $5 programmer-debugger.

About the silence from Seeed, let’s start a separate thread at Seeed Silence: What Is Going On?.

Thanks for mentioning them, but I can not go there that website is registered as NOT safe.

This is an issue that @Seeed should solve!

r.slegers Is the Embedded Computing website registered as not safe?

How strange, it is mine, hosted by Weebly with HTTPS access.

An excerpt with the useful links:

On the software side, Seeed provides the Simple DAPLink application source code and binary plus ample documentation to read.

​External resources include

@reivilo this is what I get when I go to your website… I am doing this on a company laptop, with f-secure running to block me from time to time…

In my opinion @Seeed delivered an inferior below par product. I never once in many, many years had a normal Arduino, line an Uno V3 brick on me. Never ever. The Xiao bricked within a few days. And in what I hear, and in what I read, I am most certainly not the only one with this problem.

@Seeed should present themselves as a responsible manufacturer and take back the bricked Xiao’s and replace them with a new one.

r.slegers That’s weird. I suppose all the websites hosted by Weebly are given the same treatment. Could you please try with another website of mine, also hosted by Weebly, Rei Vilo’s fischertechnik Corner?

I am still not convince by the 32-bit boards by Arduino, as they feature multiple form-factors with a limited eco-system. I really like the Adafruit Feather boards for the great software and the Feather Wing boards, and the Texas Instruments LaunchPad boards for the expansion boards called BoosterPack, the Arduino compatibility provided by Energia including multi-tasking, and the built-in hardware debugger.

@reivilo no your website about Fisher technik is okay… I have no problems accessing that.

I think I made the wrong choice. I had narrowed it down to the Xiao and the Adafruit QT Py, I guess I choose wrong… :frowning: :frowning: :frowning:

I have no explanation to why one of my websites is blocked and another authorised.

One question about the choice of the board: are you working for a company? If so, the company may have a programmer-debugger like a Segger J-Link to program and debug against the board. Similarly, it may consider designing its own board around the SAMD21.

Everytime I thought the Xiao board was bricked, the Segger J-Link came to the rescue and saved the day.

@reivilo no I am a private person. I don’t represent a company as such…

I therefore have no programmer-debugger like a Segger J-Link at my disposal.

I somewhere read that maybe by loading a new bootloader into the Xiao, like the CircuitPython bootloader and than the normal one again, that the problem might be solved…

I am going to try this maybe tomorrow.

See also:

Upload different bootloader into XIAO - Products & Technology / XIAO - Seeed Forum (

The Segger Edu mini goes for USD18 and works really great with the free Ozone debugger GUI. Again, all the details are at Segger J-Link Programmer-Debugger on my website.

My friend and I bought a number of these - and we have 3 that bricked themselves. I’m returning the ones I bought to Amazon and warning others in a review. I don’t care about a procedure to resolve the problem - I expect these products to work without me participating in their bad design or quality problems. I did try reset as did my friend - no response

That is why I no longer use them. They should refund everybody that has one that bricked because it is their fault, I did nothing wrong. I went back to using good old Arduino’s. Those never bricked on me. No more Xiao for me, I am cured.