Maix Bit Issue with firmware update

Tried using MaixPy on my device. Seemed to work with TFT and SD card. I displayed a 320x240 image.
Tried this:

import sensor, lcd

init i2c:2 freq:100000
[MAIXPY]: find ov2640
[MAIXPY]: find ov sensor




img = sensor.snapshot()

I assume it couldn’t find the camera. Google posts said to upgrade firmware. Downloaded KFlash and ran it to download latest firmware.6.2.72.
downloaded OK.
Now tft displays “Welcome to MaixPy” backward and upsidedown on blue background. Was righr side up and correct before on red background. What have I done? Still the same problem with the camera, but now I can.t write and image from sd card to the tft. Lots of errors.
Worse yet, the Kflash can no longer communicate with the device. Timeout errors.

  1. What should the latest firmware be for the MAIX Bit module?
  2. Any way to reset and reflash the board? The LED on the board flashes when I try to download, but a timeout always occurs. I’ve tried all combinations of button pressing. Nothing helps.
    Hope sombody has some ideas.