Lorawan kit

we received the lorawan kit for raspi-3, but the sd card that came in the box seems damaged, we only see the rainbow screen, is there anyway that we can download the image and burn it in a new card?


Hi there, When the firmware is broken or some terrible errors happen, you can download the firmware here. <LINK_TEXT text=“https://drive.google.com/open?id=1MVLQl … 1a0ievZRDC”>https://drive.google.com/open?id=1MVLQlxjhir_mWvKhvuqBsr1a0ievZRDC</LINK_TEXT> thanks.


I tried the steps mentioned in Wiki with the image you provided.

The board is not booting up.

After some research, I learned that images built for Raspberry Pi 3B has to be upgraded to Raspberry Pi 3B+ and Raspberry Pi 3B image may not be compatible if it is old.

I also burnt regular Raspbian image for Raspberry Pi 3B+ and it is booting fine and the board works good.

Can you provide me image for Raspberry Pi 3B+.

Or you can let me know how to build one myself with your binaries that will also help.

I know how to make image for Raspberry Pi. But I need your binaries to be included.

Hi there,

we do not have the 3b+ image yet. we confirmed the image does not work on the 3b+ system. the image is from 2017. so it is not compatible with 3b+. Please try to follow instructions from <LINK_TEXT text=“https://github.com/SeeedDocument/forum_ … 1_v1.8.pdf”>https://github.com/SeeedDocument/forum_doc/raw/master/reg/[RHF-AN01541]Set%20up%20LoRaWAN%20GW%20with%20RHF0M301_v1.8.pdf</LINK_TEXT> to build the image. It may have some issues and need debug during the instructions. thanks.

best rgds


I also have an RPi 3B+. Has any progress been made toward providing a viable OS image for the RPi 3B+?

Hi there,

please try to follow the instruction attached, we will find a time to test it and generate image later on. thanks.

Hi there,

We figure out the way for the raspberry 3b+ on 2018-11-13 image. https://www.raspberrypi.org/downloads/raspbian/

  1. Upload libssl1.0.0.deb to your Raspberry Pi, and run sudo dpkg -i ./libssl1.0.0.deb in terminal to install it. Here is the link for libssl1.0.0.deb. <LINK_TEXT text=“https://github.com/SeeedDocument/LoRaWA … l1.0.0.deb”>https://github.com/SeeedDocument/LoRaWAN_Gateway-868MHz_Kit_with_Raspberry_Pi_3/raw/master/res/libssl1.0.0.deb</LINK_TEXT>

  2. Run sudo raspi-config in terminal, select Interfacing OptionsP4 SPIYES to enable SPI, so that Raspberry Pi can communicate with RHF0M301.

  3. Run following commands in terminal, download and start loriot gateway.

wget <URL url="https://cn1.loriot.io/home/gwsw/loriot-pi-3-rhf1257-SPI-0-latest.bin"><LINK_TEXT text="https://cn1.loriot.io/home/gwsw/loriot- ... latest.bin">https://cn1.loriot.io/home/gwsw/loriot-pi-3-rhf1257-SPI-0-latest.bin</LINK_TEXT></URL> -O loriot-gw<br/>
chmod +x loriot-gw<br/>
./loriot-gw -f<br/>

Well, this has been a frustrating and so far fruitless exercise. I tried to follow the directions in [[RHF-AN01541]Set up LoRaWAN GW with RHF0M301_v1.8.pdf][<LINK_TEXT text=“https://github.com/SeeedDocument/forum_ … 1_v1.8.pdf”>https://github.com/SeeedDocument/forum_doc/raw/master/reg/[RHF-AN01541]Set%20up%20LoRaWAN%20GW%20with%20RHF0M301_v1.8.pdf</LINK_TEXT>] but got stuck here
</s><i> </i>cd ~/risinghf/packet_forwarder/ sudo ./reset_pkt_fwd.sh start <e>
This build nowhere has a command </s>reset_pkt_fwd.sh<e> .

I tried </s>~/risinghf/lora_gateway/libloragw/test_loragw_reg<e> but got errors, the last are:
</s><i> </i>... ###MISMATCH### reg number 325 read: 2 (2) default: 0 (0) End of register verification IMPLICIT_PAYLOAD_LENGHT = 0 (should be 197) FRAME_SYNCH_PEAK2_POS = 2 (should be 11) PREAMBLE_SYMB1_NB = 10 (should be 49253) ADJUST_MODEM_START_OFFSET_SF12_RDX4 = 4092 (should be 3173) IF_FREQ_1 = -128 (should be -1947) End of test for loragw_reg.c <e>

So my system failed. But how? What can I do about it? I tried all of the other tests but many appeared to fail and I don’t know what to try to fix the problem.

What can I do next?

Hi there,

I create a image which supports raspberry pi 3b and 3b+, you can burn to your sd card. you just need to run below code. the raspberry pi can forward the message to loriot server. here is the link of the image. <LINK_TEXT text=“https://drive.google.com/open?id=1wO9dn … TIQpWSz-cZ”>https://drive.google.com/open?id=1wO9dnTbYub8nq7qFgCpu9QTIQpWSz-cZ</LINK_TEXT>

</s><i> </i>./loriot-gw -f <e>

Here is the log of the ./loriot-gw -f. you also can add the command into the boot up process as well. thanks.

pi@raspberrypi:~ $ ./loriot-gw -f

[2019-03-28 05:03:53.546][DEBUG] No interface set

[2019-03-28 05:03:53.547][LOG ] Gateway loriot_rhf_spi version 2.8.911-JKS-CN-2.8.911

[2019-03-28 05:03:53.547][LOG ] Openssl version OpenSSL 1.0.1t 3 May 2016

[2019-03-28 05:03:53.548][LOG ] Using eth0 for GW EUI B827EBFFFFD0FC17

[2019-03-28 05:03:53.549][LOG ] Requesting system route

route attribute type: 25

00000000 e8 03 00 00 24 00 0c 00 |…$…|

[2019-03-28 05:03:53.550][LOG ] Connecting config server cn1.loriot.io

[2019-03-28 05:03:53.577][LOG ] SSL: Will use internal certificate validation

[2019-03-28 05:03:53.615][DEBUG] Hostname cn1.loriot.io addr

[2019-03-28 05:03:53.871][Cfg ] HTTP response HTTP/1.1 200 OK

[2019-03-28 05:03:53.871][Cfg ] Timestamp Thu, 28 Mar 2019 05:03:53 GMT

[2019-03-28 05:03:53.871][Cfg ] Content-type application/json; charset=utf-8

[2019-03-28 05:03:53.872][INFO ] Parsing configuration file …

[2019-03-28 05:03:53.873][INFO ] 5 configuration parameters found

[2019-03-28 05:03:53.873][INFO ] lorawan_public 1, clksrc 1

[2019-03-28 05:03:53.873][INFO ] no configuration for LBT

[2019-03-28 05:03:53.873][INFO ] antenna_gain 0 dBi

[2019-03-28 05:03:53.873][INFO ] Configuring TX LUT with 16 indexes

[2019-03-28 05:03:53.873][WARN ] no frequency range specified for TX rf chain 0

[2019-03-28 05:03:53.874][INFO ] radio 0 enabled (type SX1257), center frequency 867500000, RSSI offset -166.000000, tx enabled 1, tx_notch_freq 0

[2019-03-28 05:03:53.874][INFO ] radio 1 enabled (type SX1257), center frequency 868500000, RSSI offset -166.000000, tx enabled 0, tx_notch_freq 0

[2019-03-28 05:03:53.874][INFO ] Lora multi-SF channel 0> radio 1, IF -400000 Hz, 125 kHz bw, SF 7 to 12

[2019-03-28 05:03:53.874][INFO ] Lora multi-SF channel 1> radio 1, IF -200000 Hz, 125 kHz bw, SF 7 to 12

[2019-03-28 05:03:53.874][INFO ] Lora multi-SF channel 2> radio 1, IF 0 Hz, 125 kHz bw, SF 7 to 12

[2019-03-28 05:03:53.874][INFO ] Lora multi-SF channel 3> radio 0, IF -400000 Hz, 125 kHz bw, SF 7 to 12

[2019-03-28 05:03:53.874][INFO ] Lora multi-SF channel 4> radio 0, IF -200000 Hz, 125 kHz bw, SF 7 to 12

[2019-03-28 05:03:53.874][INFO ] Lora multi-SF channel 5> radio 0, IF 0 Hz, 125 kHz bw, SF 7 to 12

[2019-03-28 05:03:53.874][INFO ] Lora multi-SF channel 6> radio 0, IF 200000 Hz, 125 kHz bw, SF 7 to 12

[2019-03-28 05:03:53.874][INFO ] Lora multi-SF channel 7> radio 0, IF 400000 Hz, 125 kHz bw, SF 7 to 12

[2019-03-28 05:03:53.874][INFO ] Lora std channel> radio 1, IF -200000 Hz, 250000 Hz bw, SF 7

[2019-03-28 05:03:53.874][INFO ] FSK channel> radio 1, IF 300000 Hz, 125000 Hz bw, 50000 bps datarate

[2019-03-28 05:03:53.875][DEBUG] Connecting update server

[2019-03-28 05:03:54.105][DEBUG] Hostname cn1.loriot.io addr

[2019-03-28 05:03:54.349][Cfg ] HTTP response HTTP/1.1 204 No Content

[2019-03-28 05:03:54.350][INFO ] No update available for current version

[2019-03-28 05:03:54.350][LOG ] Starting LoRa Concentrator

[2019-03-28 05:03:54.350][DEBUG] Resetting LoRa Concentrator (pin 7)

FPGA version 0

[2019-03-28 05:03:57.781][LOG ] LoRa starting HAL 5.0.1

ERROR: Spectral Scan is not supported (0x8)

[2019-03-28 05:03:57.784][DEBUG] gpsThread starting

[2019-03-28 05:03:57.784][DEBUG] gpsThread end


[2019-03-28 05:03:57.882][LOG ] Connecting websocket server cn1.loriot.io

[2019-03-28 05:03:57.921][DEBUG] Hostname cn1.loriot.io addr

[2019-03-28 05:03:58.180][NWK ] HTTP response HTTP/1.1 101 Switching Protocols

[2019-03-28 05:03:58.180][NWK ] Connection to network server established.

route attribute type: 25

00000000 e8 03 00 00 24 00 0c 00 |…$…|


route attribute type: 25

00000000 e8 03 00 00 24 00 0c 00 |…$…|


{“cmd”:“gwsysinfo”,“uname”:{“machine”:“armv7l”,“name”:“raspberrypi”,“release”:“4.14.79-v7+”,“sys”:“Linux”,“version”:"#1159 SMP Sun Nov 4 17:50:20 GMT 2018"},“storage”:[{“free”:14443298816,“size”:15605321728,“folder”:"."}],“free”:713400320,“size”:972234752,“loads”:[0.27,0.20,0.09],“uptime”:300,“cpus”:4}


[2019-03-28 05:03:58.182][DEBUG] Connecting ssh server cn1.loriot.io

[2019-03-28 05:03:58.217][DEBUG] Hostname cn1.loriot.io addr

[2019-03-28 05:03:58.897][NWK ] HTTP response HTTP/1.1 101 Switching Protocols

[2019-03-28 05:03:58.897][LOG ] SSH Tunnel server cn1.loriot.io connected

[2019-03-28 05:04:00.782][LOG ] TX Status 00 -> 80


I downloaded the latest image just posted for the Rasberry 3B and started the boot process. However, I cant login to the Pi. I tried the default username and password (pi and rasberry) but I cannot get pass the login. Also tried rxhf and rising hf but no luck. Is there a specific login written into the latest image you provided for the Pi3?

Please let me know.

Hi there,

the user name is pi and password is raspberry for the new image which support 3b and 3b+. thanks.

what steps should I follow to configure the 3b+ image

how to configure wifi module…

Do you have any video tutorial?

I would need detailed steps on how to operate the gateway with the raspberry pi3b + 915MHz


i wait for your reply

Hi there,

if you use the my previously image, the user name is pi and password is raspberry. thanks.