KiwiSDR Dead on Arrival DOA not booting

Hi Team,
We got this KiWi SDR and it does not appear to work. Please find the list of troublshooting we did and also a video showing issue.

  1. card insertion checked and its just fine.
  • also flashed a new spare card with Stretch from here

  • same result; LEDs go though brief startup procedure then into the repetitive cycle with no booting and no internet activity

  • a few minutes later the Beaglebone shuts down totally with all LEDs out

note: removing the card and attempted booting does not produce the results above, it’s quite different.

  1. I initially used an existing linear 3A supply via the barrel connector.
  • have checked current drain using a calibrated bench supply feeding a second 12V to 5V linear regulator and their is normal current drawn by the BB

  • have used the same setup with my Raspberry Pi’s with no problems

Removing the Kiwi cape and powering the BB via the USB port with a Pi4B switch mode supply makes no difference.

There is no possibility that power is an issue.

3.With or without the Kiwi CAPE, on power up with ethernet & GPS connected and the microSD correctly inserted, the LEDs begin a repetitive cycling which lasts for a minute or two. Shortly after that the BB powers down and all its LEDs go out.

Testing without the CAPE was done with a standard Raspberry Pi power supply. Voltages are fine, 5.06 volts

Apart from the obvious checking everything and trying again there doesn’t appear anything obvious to try.

KiWiSDR video
Let me know if you need further info.

@Pakronics I saw your vedio, according the light status, beagle board are in flashing mode. The board will be shut down after flashing. Remove the card and reboot the board then connect a serial cable to cat the info.

Hi @Pakronics

Also Do you have a USB Uart lying around. May be seeing the serial log will also help to debug what is going on with the system boot.


For people having similar issue -

Problem: The comment on the forum from Bruce.Qin re the flashing light sequence was correct.

Solution: Downloading the latest software and using that to re-flash the onboard eMMC as per the BB green instructions worked fine.