A link in the shop don’t work anymore.

  1. jyetech.com/Products/LcdScop … -06v02.pdf

(assembly instructions)

I have some problems with finding it on their website. I’m just no good at reading Chinese.

You can reach that document here matey: dpcav.com/data_sheets/DN062-06v02.pdf

Thanks for spotting that, I’m sure they’ll jump on it shortly

Hmm, that seems to be a normal user manual.

As I’m thinking about getting a KIT to feed my soldering obsession, some assembly hints would be great. The link in the depot made be think there’d be just that in the PDF.

The original link was updated to a new version, fixed now: jyetech.com/Products/LcdScope/DN062-07v03.pdf


Hi Madworm,

I just soldered one of these together, but it was quite a challenge because of the many small (SMD) parts.

Nevertheless, I got it finished in about 2.5 hours (I am not that fast).
Here are some assembly tips:

  • I soldered the SMD ICs first, watch out they are oriented properly (Pin1)
  • then I did the rest of the small SMD parts, starting with the ones that were only one resistor or capacitor per value (that was just my personal approach, that way it looked like I was making more progress
  • I only unpacked one resistor/capacitor value at a time, since they are so small you cannot read the values, you don’t want to get them mixed up
  • after that I soldered in the other parts, large capacitors and switches
  • I used a headlamp for good illumination and tweezers to position the components
  • clean your soldering iron frequently, use soldering lead sparingly
  • as in the assembly instruction document, check the 5V voltage first, then connect the jumper J1 and check again for 5V voltage
  • then I soldered in the LCD, but check that there no bad connections underneath the LCD, you will not get to them afterwards.
  • also, I cut the leads of connector J4 underneth the LCD very short so that they don’t make accidental contact with the LCD and the LCD fits all the way onto the board
  • the LCD I got did not fit into the front panel opening, I had to file a little bit of material away to get the LCD to fit into the palen opening

And lo and behold, after I soldered in the LCD and applied power, it was all working. I was very happy about that, since I don’t know if there are any good troubleshooting options if it does not work.

In hindsight, at least for me, it was a great experience since its all working, but SMD soldering is really challenging, at least with the tools I had (regular soldering iron).

Hope that helps,

I soldered my scope,

  1. checked that I got 5V from TP5 (same thing after shorting JP1)
    2.I soldered the LCD and started the scope again

LCD was lit and showing me the firmware version but immediately after that the Q1 fried (with puff of smoke) :frowning:
I noticed also that the insulating tape from L2 was partly melted.
Any suggestions where to start the problem hunting? (and where to get the replacement parts?


The first time I turned on my Oscilloscope the LCD contrast was fine, then after using it and turning it it back on the contrast is very low and it is hard to read the screan.

Any suggestions to modify the LCD contrast?

I was usonmg a 9 volt battery and it drained quickly to 7.65 volts and was the cause of the low contrast.
Used a 9 volt power supply and now it works great.

Hi All,
I’ve finished putting together the Oscilloscope kit, but have a problem!

It powers up fine, but when connected to a signal source, nothing shows up on the display apart from the grid, etc.

The frequency counter function works - so I can confirm that the probe is hooked up and receiving a signal.

Any suggestions on where to start looking to trouble shoot would be great :slight_smile:


EDIT Sorted :slight_smile: Had D7 reversed.

Thought I would share:

Working perfectly - What a thing of beauty!


Hi all,

I noticed the v05 bom I received in the kit (103-06201-05) has a few parts missing
that are still on the silk of the board.

At a firtst check, it’s about the LCD DN2 circuitry:
C28, C26 and DN2

[ on a side note, there is still also (and I don’t care) D1 to D5 into the V5 BOM ]

The only reference to C26/C28 I found was in DN062-02v04.pdf . A collegue
of mine roughtly translated the part 4.2, about the lcd check, and confirmed me
it’s a “make sure everything is correctly soldered around DN2 so the lcd
could work”

Could someone enlighten me on this ? Do I have to find the 3 missing parts
by myself or I really don’t have to care about this and leave the free pads apart ?


Ok, i’ve just finished to build the scope. It works perfectly. What a wonder for the price. Yeah!
I don’t worry anymore with the missing caps for the lcd. Has it says, just solder what’s in the bag. That’s it.

It was the first time for me dealing with smt soldering, and now I can say it won’t be the last time. I really like it.

Seeed guys, if you have a chance to meet Mr. Liu, please send him my thanks.


New Firmware out : 113-06201-080

And new Operating Instruction : DN062-06v04.pdf

113-06201-080 [ 2009.07.06 ]
Higher real-time sampling rate - 5Msps (5Msps works in AUTO mode only)
Significant faster display refresh rate
External trig is now available
Save up to 6 captures to EEPROM and retain after power down
Retrieve and display saved captures
Transfer its screen to PC as bitmap file via serial connection


I just finished it and now I’ll have to take it apart again for the update :wink:

BTW, in my KIT the front panel didn’t match the LCD. The hole was too small. I fixed it, but did anybody else have that problem ?


Just an important note: the 10pin header on the PCB is NOT standard 10pin ISP layout and will short 5V / GND if you connect a programmer.

Edit 2:

I would not update the firmware. Since my update the scope shows some strange characters for SEC/DIV. Timebase is completely borked. Only thing that still works is frequency measurement and V/DIV. Going back to the old firmware (downloaded from jyetech site) doesn’t fix that :frowning:

Edit 3:

It seems that after the update to -080 the device was in some kind of illegal state that wasn’t fixed by going back to -070. Pressing the +/- buttons in SEC/DIV in one direction finally showed good stuff. This also works with -080. After that the strange characters and timebase error was gone. Also note that the ADC doesn’t get power when J1 is not connected! If your programmer supplies power, only the CPU and the display runs, but not the ADC.

Edit 4:

I was able to trigger the illegal state of the scope by using the new save to eeprom / read from eeprom feature. Definitely going back to -070 now.

Edit 5:

The fix only lasts till reboot, so I think its a firmware problem, maybe buffer overflow or whatever. Could anybody download the -070 firmware from a working device with avrdude and post that ? I’m not sure if the firmware on the jaytech site is OK. Should have made a backup. Darn.

Edit 6:

The eeprom is not erased when flashing the chip, maybe some bad data from the old firmware was left ???

While I’m at it, I’d also need the eeprom file!

read flash from cpu:

avrdude -c usbtiny -p m64 -U flash:r:program.hex:i

read eeprom from cpu:

avrdude -c usbtiny -p -U eeprom:r:eeprom.hex:i

I’d be glad to get those 2 files :wink:

Oh BTW, the manual says, that programming needs these files:

a) firmware
b) bootloader
c) eeprom file

only the firmware can be found on jyetechs website ;-(

OK. Listen up!

avrdude -c usbtiny -p m64 -U lfuse:w:0xAE:m -U hfuse:w:0xC0:m -U efuse:w:0xFF:m
avrdude -c usbtiny -p m64 -U eeprom:w:113-06201-080.eep -B 100
avrdude -c usbtiny -p m64 -U flash:w:113-06207-020.hex
avrdude -c usbtiny -p m64 -D -U flash:w:113-06201-080.hex

So IF you want to update, you need the firmware from the jyetech site + the eeprom file + the bootloader file.

Windows users can use a GUI uploader and the bootloader, which seems to be safer. Linux users will have to go the upper way.

Jyetech sent me the files, but I don’t know if I can release them to the public on my blog. Anyone who needs them can send me a PM.

Another comment:

the RCA plug used to build the probe cable doesn’t fit properly at all. It is so loose that if you don’t pull on the cable to tension it, ground is disconnected ;-(

Standard audio RCA cables from my old cd player fit perfectly… It seems I got the one scope with all of the bugs… I’d prefer paying 1 or 2$ more for a better RCA plug.

  • About the lcd Frame not fitting, yes, I got the same problem. It doesn’t fit well and I needed to file it a bit.

  • The RCA jack is loosing too, here, but I do not have any issue with ground connect.

  • Jyetech should definitively post all the needed files, like

    • the eeprom
    • the bootloader (and why not the source code for it so we could at least write our own firmware uploading software, no winwin here).
    • The schematic, in pdf or something, because the printed one is in grayscale, and the folds due to packaging the kit erased a lot of text.
  • by the way, do you know, endorse or support the german custom firmware attemp made in june ? Am I authorised to post the link ?

I’m now in 080, and no problem so far.

Here is what I’ve done :

I don’t have any avr programmer, but a trusty ftdi 3.3 cable.
I cut 4x1 male pins (and not 1x4, in order to unsolder it easily later), and solder then to
J5, pins 13, 15, 17 and 19

Then I made an adapter to the ftdi cable, picking +5v (red), GND (black), RX(Yellow), TX(Orange)

Of course, RX (on DSO) is TX (on FTDI).

(click to see bigger ones)

I was really surprised to see the DSO light up when I plugged the usb to my computer.

(Yeah, a cheap power supply)

But it didn’t want to talk to the dso. I then unsolder the red wire (+5V) from my adapter.
It was then: easier to synchronise the upload with the power up, and working !

The 080 fw update was uploaded in a few seconds, and started without powering off the dso.
I then met the same issues as madworm. The interface freezed, no button available, randomly,
bouncing [hold] button…

So I powered off and on the dso, It booted normally, then all was working

The refresh rate is fantastic, all the new functions (save, dump, …) are really cool but a bit disturbing
There is no indicator when it displays a live view or a snapshot, for example. It would be great to
use the display to indicators, to do that, if available.

I then resoldered the +5V, until I find a little switch to place between the two connectors.

Great work, Mr Lyu.

this small adapter also works great with the Capacitor Meter Kit, and once again, no need power supply when
ftdi cable is in action.