Jetson Nano with A203 v2 carrier board - GPIO not working?

I have a Jetson Nano on a A203 carrier board. I used the instructions to flash the os to the device using the command line. This worked to flash the OS, but the update drivers part always fails. I get the following output:

Error: Return value 4

Command tegradevflash --write kernel-dtb /home/grahambriggs/nano/Linux_for_Tegra/bootloader/signed/kernel_tegra210-p3448-0002-p3449-0000-b00.dtb.encrypt

Failed to flash/read t210ref.

I modified the procedure and when I copy the dtb to the linux folder before the first flash, and this works - sort of. There are two problems

  1. SD card is not recognized when I put it in the SD card holder
  2. GPIO pins do not work, or at least are not mapped to the same configuration as the dev board, which manifests itself as system crash when I try to use JetsonGPIO to open a pin.

Regarding the second problem. Should I expect the A203 carrier board GPIO to work the same as the nano development kit? Has anyone successfully used JetsonGPIO to control pins on the A203 board?

Is there a tutorial or guide showing you how to configure the A203 pins to be equivelent to the dev kit carrier board.

Thanks in advance for your time and attention to help out with this problem



I had similar problem and GPIO pin seem not working. Did you manage to get it to work? I tried contacting seeedstudio, but they are not much of help.

I did get it to work. This issue was my problem and not actually a problem with the A203 v2 board or the seeed studio drivers.

I am working in C (C++) and I was using the JetsonGPIO library (, which turns out only works on the dev carrier board. When I switched to using JETGPIO library (, I was able to use the GPIO pins of the A203 carrier board.

For me, this issue is resolved.



I tried to update the drivers using terminal, i got the same error output as you. How do you overcome that? And by the way, can we actually connect a LED directly to GPIO pin to get it to lit up which is similar to how a Raspberry Pi works?

I am still stuck on getting the driver update to work. This is annoying but not critical to me. With the failing driver update, I can still use the device, except for the SD card which does not work, and probably the camera which I have not tried yet.

Regarding lighting up a LED: No you can not connect a LED directly to a GPIO pin and get it to light up (it may not come on at all or at best glow very dimly).

The Jetson Nano GPIO works at 1v8 logic levels, and then go through a TI TXB0108RGYR level shifter. I am not an expert, but I think it has something to do with interfacing with CMOS sensors where the board can detect the load attached and behave accordingly with the right logic level. Please see this developer note (you have to log into your NVIDIA developer account first):

You can see this if you try to connect a multi meter or oscilloscope to the pin. You will notice it is 1V8 when HIGH and something like 1V3 when low. I believe this is because the board thinks the high capacitive load of the multimeter (or a directly wired LED) is something that wants 1v8 logic level. See this thread for additional explanation.

If you want to light up a LED with the Jetson GPIO, you need to use a transistor such as this one, or a Darlington such as this one.