Jetson Nano on A203 SD card not working

I have a Jetson Nano on a A203 carrier board. I used the instructions to flash the os to the device using the command line. This worked to flash the OS, but the update drivers part always fails. I get the following output:

Error: Return value 4

Command tegradevflash --write kernel-dtb /home/grahambriggs/nano/Linux_for_Tegra/bootloader/signed/kernel_tegra210-p3448-0002-p3449-0000-b00.dtb.encrypt

Failed to flash/read t210ref.

I modified the procedure and when I copy the dtb to the linux folder before the first flash, and this works - sort of. There are two problems

  1. SD card is not recognized when I put it in the SD card holder
  2. GPIO pins do not work, or at least are not mapped to the same configuration as the dev board, which manifests itself as system crash when I try to use JetsonGPIO to open a pin.

Regarding the first problem - SD card not working:

I have read a few others on this forum having trouble getting SD card to work. Can anyone help or provide insight on why this might be faulty? My eventual goal is to be able to run the Nano on A203 with the OS on the SD card, but I don’t want to move onto this step until the device can recognize the SD card when running on the OS installed to the built in storage.

Thanks in advance for your time and attention to help out with this problem


I am having this exact same problem, with the same end goal (being able to run the OS from the SD card after installing the base system on the flash memory). I am using a Jetson Nano production module with A203 v2 and Jetpack 4.6. Some input from seeed would be helpful.

Hello, sorry for my late reply. If you want to use the SD card function on top of the A203 carrier board, then you need to install the A203 driver for your OS first. Please refer to the wiki here for the detailed procedure.

Next, if you need to boot the system from the SD card, then you need to use our expansion tutorial to transfer the file system from the eMMC to the SD card. Please refer to the steps here.

As for the problem of GPIO pins not working as you mentioned, the non-public version of the carrier board needs to use the GPIO library of Raspberry Pi, you can try it.

I have done this and SD card still doesn’t recognize as well as the m2 wifi card I put in shows up under usb devices and the bluetooth works but the wifi does not I have followed the instructions on the wiki I have a 4gb production nano on a v2 a203

Hi, I am having the same problem.

Same here, I think the issue kicked in after I restored a previous eMMC image. Before that I definitely had it working at one point thanks to the .dtb file provided, though. And the eMMC image I restored with was made after the SD card reader worked. Unsure why the settings wouldn’t persist after imaging…

Anybody else have any more information on how to restore the drivers to working order?