Jetson Mate network issues

Hey, I’m having issues with my Jetson Mate board.

Under network usage (not a lot, just normal usage, streaming some cameras into
a single board) the network will sometimes stop working, then I need to disconnect
and re-connect the ethernet cable, and then it comes back.

The ethernet lights look normal in both the Jetson Mate and the switch.

I have tried a different switch, and also different cables, but still having the same

I suspect the microchip Gbe switch is toasting?, I tried to add a heatsink, but that doesn’t seem to be
the problem. May be an issue with power?

This happens to my jetson mate (with 4 jetson xavier inside) too.

We do also experience the same problem! We have two Jetson Mate, and we’re facing the same issue on both of them!!!
When the internet goes down it also takes down the whole switch and every other computer hooked up to it. To fix the issue, we needed to reboot the switch, I needed to manually disable/enable the network interface on Jetson Mate to make it work again.

I have also described it here: Internet Connection randomly goes down - Jetson Xavier NX - NVIDIA Developer Forums on Nvidia Forum, but they recommended me to talk to the manufacturer, Seeedstuido. So I’m having an ongoing email conversation with them atm about this issue.

Hi guys,
I’m helping to debug this issue but I can not reproduce it yet.

What I konw is the SYS_RST* signal on master node controls the power supply for peripherals like GB switch.
Can you check that when the ethernet goes down, is the Master node working or in shutdown status.

My Jetson NX SOMs have same trouble.
NX0: network down everyday (Reboot and Down ,Reboot and Down…Endless)
NX1: usually active
NX2: usually active
NX3: usually active

NX0 connects MotherShipPC using USB and command “sudo reboot”.

Is there a solution for this ??? I am facing same problem with Jetson-Mate.
Board is not stable with Network connection
You will have to hit wake switch for re-establishing network connection.

Hi guys,
Through a period of debugging, I found the cause of the network problem. The issues documented in the silicon errata are similar to ours. According to the errata, I made a patch file, and the patch content can be written to the registers of the onboard switch through the master node.
This will solve the network problem.

  1. Download the patch file to your master node. If JetsonNano is in your master node, using this file. If JetsonNX using this file.

  2. Make the file excutable by using

    chmod +x <patch file>.
  1. run the patch file
    ./<patch file>