J401x Jetpack 6.0 compatibility

Hi all,

Does the J401x Nvidia Jetson Orin NX supports the new version of Jetpack 6.0? Documentation is not updated yet and some people on Discord channel mentioned problems with kernel updating. Could you put a comment on this?

1 Like

I’m sorry, but currently, there is no support for JP6 on J401x Nvidia Jetson Orin NX. If there are any updates, we will mention it on the Weekly Wiki as soon as possible. Thank you for your understanding and patience.

Hi Seraphina, is there a plan about Seeed to provide support for JP6? … apparently there is a lot of interest around.

We sincerely appreciate everyone’s valuable suggestions. We will definitely take them into consideration :grinning:

Hello,

was also looking for a solution to flash JP6 to my Orin NX 8GB. Found a way to flash it.
Basically I have used this how to:
https://wiki.seeedstudio.com/reComputer_J4012_Flash_Jetpack/

Modification I had to do in order to make it work.
Step 1: download latest driver from here: https://developer.nvidia.com/embedded/jetson-linux-r362
Step 3: folder structure changed to:

cd Linux_for_Tegra/bootloader/generic/BCT

Step 6: again the folder structure changed and you should not use the --network parameter. Also the conf file name changed from p3509-a02+p3767-0000 to p3509-a02-p3767-0000.

sudo ./tools/kernel_flash/l4t_initrd_flash.sh --external-device nvme0n1p1 \
  -c tools/kernel_flash/flash_l4t_external.xml -p "-c bootloader/generic/cfg/flash_t234_qspi.xml" \
  --showlogs p3509-a02-p3767-0000 internal

Thats it.

Best regards.

1 Like

Unfortunately I could not flash by this method for the J4012 Orin NX 16GB. It seemed stucked with Waiting for target to boot-up... and ended up with Timeout. Cleaning up... while “Step 3: Start the flashing process”.

Hello,
I was facing the same issue. That’s why I have removed the -network parameter in step 6.

Yeah, That’s what I exactly tried the command without --network usb0 parameter as you suggested. It was same result as -network parameter or no. Thank you, mephiii.

Continuing the discussion from J401x Jetpack 6.0 compatibility:

I have the same issue.


  •                                 *
    
  • Step 3: Start the flashing process *
  •                                 *
    

Waiting for target to boot-up…
Waiting for target to boot-up…
Waiting for target to boot-up…
Waiting for target to boot-up…
Waiting for target to boot-up…
.
.
.
Waiting for target to boot-up…
Waiting for target to boot-up…
Timeout
Cleaning up…

using lsusb I see:

Bus 003 Device 043: ID 0955:7020 NVIDIA Corp. L4T (Linux for Tegra) running on Tegra

Strange that the device is visible after reboot. Have you performed step 4?
Step 4. Remove the jumper wire

@Seeed_Seraphina Do you have any plan to support JP6 ? It seems a bit irresponsible to say just wait for the wiki post and no updates for months.

1 Like

@Seeed_Seraphina It’s been quite a while before any updates, is jetpack 6 support something we can expect, or are the J401x boards not going to receive any future updates from seeed?

Hi there,
Probably on New Year, However I would bet YES, why wouldn’t they support JP6 ?
Nvidia is all in on the JetPack So…
my .02
GL :slight_smile: PJ

Due to the previous period during the Chinese New Year holiday, replies were not always timely. We are currently preparing the system image for JP 6.0. Please stay tuned!

3 Likes

@Seeed_Seraphina Thanks for the update.
Can you already give a rough time estimate on when we can expect the new system image?
Best wishes

Hi! We’d also like to know when the image will likely be available. Thanks!

Hi Seed any advice on when this will be available? I have purchased 2 x Jetson NX 16Gb on J401 (SG$ 2600) and right now they are pretty much useless as I am not able to use the latest version of Pytorch (amongst other things)

Hello, our engineers will include JP6 in their plan. However, as the JP6.0 released by NVIDIA is a trial version with limited functionality, we are waiting for them to release a more complete version. We appreciate everyone’s understanding and support, and we are committed to delivering a more stable version to all.

1 Like

I was able to get my J401 Orin NX 16GB to take an image via the standard sdkmanager GUI on an Ubuntu 22 host. Worth noting that I had issues with the devkit overheating before bootup was detected as reflected in some of the errors above, which I resolved with a hairdryer blowing on the heatsink while it was flashing. I also have a 1TB SSD installed, which might play a part in my success as well.

Just wanted to add my +1 on this - getting this properly resolved would be really helpful for us (we have several J401s, and the JP5 CUDA version is barring us from upgrading to the latest torch/JAX). Unfortunately we haven’t had any luck with the workarounds mentioned above.