Invalid library found

Invalid library found in C:\Users\nate8\AppData\Local\Arduino15\packages\Seeeduino\hardware\mbed\2.9.0\libraries\Spi_Flash: no headers files (.h) found in C:\Users\nate8\AppData\Local\Arduino15\packages\Seeeduino\hardware\mbed\2.9.0\libraries\Spi_Flash

Have you progressed on this error, I suddenly have the same error?

From Boards Manager Select
Seeed nRF52840 mbed-enabled Boards by Seed Studio

In Preferences > Additional boards manager Urls> Cleared everything and select

From Tools>
COM??? (Seeed Xiao BLE - nRF52840, Seeed Xiao BLE Sense - nRF52840)

Worked for me.
Good Luck

getting the same error but only when i use the mbed version of the board.

I am trying to setup Arduino IDE for the Seeed XIAO nRF52840 sense. Have the same problem. I wondering what is the mbed and without mbed version?

I am trying to use this board as well and get the same invalid libraries error about SPI flash! I do not see where this is resolved.

This seems to work for me if I reset or do a double reset to place my Sense nRF board into boot loader mode. Usually I can upload with one reset. Its intermittent though.