Installing ReSpeaker 2-Mic Hat not working - Unable to locate package and kernel version issues

Hello,

I am trying to set up a ReSpeaker 2-Mic Hat on my Raspberry Pi, but I am encountering issues during the installation process. I followed two different methods to install the driver, but both have failed.

I tried installing the driver using the following github repos:
/Seeed-Projects/seeed-voicecard.git

/respeaker/seeed-voicecard

For both methods, I encountered this error message:

Hit:1 Index of /debian bullseye InRelease
Hit:2 Index of /raspbian bullseye InRelease
Reading package listsā€¦ Done
Building dependency treeā€¦ Done
Reading state informationā€¦ Done
All packages are up to date.
Reading package listsā€¦ Done
Building dependency treeā€¦ Done
Reading state informationā€¦ Done
raspberrypi-kernel is already the newest version (1:1.20230405-1).
raspberrypi-kernel-headers is already the newest version (1:1.20230405-1).
The following package was automatically installed and is no longer required:
libfuse2
Use ā€˜sudo apt autoremoveā€™ to remove it.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Reading package listsā€¦ Done
Building dependency treeā€¦ Done
Reading state informationā€¦ Done
E: Unable to locate package linux-raspi
E: Unable to locate package linux-headers-raspi
E: Unable to locate package linux-image-raspi
Reading package listsā€¦ Done
Building dependency treeā€¦ Done
Reading state informationā€¦ Done
dkms is already the newest version (2.8.4-3).
git is already the newest version (1:2.30.2-1+deb11u2).
i2c-tools is already the newest version (4.2-1+b1).
libasound2-plugins is already the newest version (1.2.2-2).
The following package was automatically installed and is no longer required:
libfuse2
Use ā€˜sudo apt autoremoveā€™ to remove it.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
dpkg-query: package ā€˜linux-headers-ā€™ is not installed
dpkg-query: package ā€˜6.1.21+ā€™ is not installed
Use dpkg --contents (= dpkg-deb --contents) to list archive files contents.
!!! Your kernel version is

6.1.21+
Not found *** corresponding *** kernel headers with apt-get.
This may occur if you have ran ā€˜rpi-updateā€™.
Choose *** y *** will revert the kernel to version then continue.
Choose *** N *** will exit without this driver support, by default.

Additionally, after running the second method and rebooting, I got the following warning:

WARNING Your loaded kernel version is 6.1.21
Not matching the updated version 6.1.21.
Kernel was updated, but new kernel was not loaded yet
Please reboot your machine AND THEN run this script again

Despite rebooting and running the script again, I still faced the same issue. I have modified my /boot/config.txt file to include dtoverlay=seeed-2mic-voicecard, and also tried to manually set the kernel version in install.sh but the problem persists.

Could you please help me resolve these issues and get the ReSpeaker 2-Mic Hat working on my Raspberry Pi? Thank you in advance.

Best regards

hi , Iā€™ve the same issue , Iā€™ve test many 32 or 64 bit image , just the legacy 32bits rip image are ok !

Bump for this, Iā€™m encountering the same thing, exact same output. Tried on both a RPi Zero W (v1.1) with 32-bit latest Raspbian fresh install, and RPi4 with 64-bit Raspbian frest install.

Also tried emailing them at techsupport@seeed.io, but havenā€™t gotten any reply yet.

Just heard back from Seeed tech support the email I got. They actually said to use this repo. I asked them why they hadnā€™t bothered to update the wiki with a note or something. Just sent it a few minutes ago, so havenā€™t heard back yet.

That has done it, working now. Ugh.

@andwoh3 @chacal tagging you in case you didnā€™t get any notification of this.

EDIT: And I just got this back from their email support. Are you FREAKING KIDDING ME.

Hello.
We have discontinued software support for the respeaker product line because some customers have integrated respeaker into their devices and we still sell it as a hardware device.

Regards!

2 Likes

I used the repo that drizzt321 provided and am still receiving the error mentioned by OP.

Has anyone run into this error and found a solution?