I am not able to work with my Tessel 2 that I just bought

Hello friends,

I have just got my new Tessel 2 board and I am not able to use it from my Linux machine.
I have BullsEye 11.0 (Pi-OS) installed with the latest nodejs 18.4.1 LTS installed and the t2 cli installed as well.
I have followed the Seeed Studio documentation and did as mentioned in the instructions.

I was able to authorized the Tessel OpenWRT OS with my machine and also been able to connect to it directly from an IP that I got when I connected it to a switch in my Lab network.
This is as far as I was able to get.

I am able to get a respond when doing

t2 list

and sometimes I also get a line that shows that it can list a LAN as well
But most of the times I get:

INFO Searching for nearby Tessels...
        USB     Tessel-02A338563F88

I am not able to connect to the wifi at all, it gets stuck when I try.

root@server1:/home/# t2 wifi -l
INFO Looking for your Tessel...
INFO Connected to Tessel-02A338563F98.
INFO Scanning for visible networks...

It stays like that for a very long time till I press CTRL+C
I do have a lot of IoT devices in my home and I do have 2.4G Wi-Fi that I tried to connect with with no luck at all. I placed it as close as I can get with one of my Wi-Fi AP that is 2.4G and it could not find it as well.

I wanted to start developing with the board using the simple blink js that I found online and also I have not succeeded at all - this is the blink.js from j5ik

var Tessel = require("tessel-io");
var five = require("johnny-five");

var board = new five.Board({
  io: new Tessel()

board.on("ready", () => {
  var led = new five.Led("L2");

I tried running it t2 run blink.js and without any luck at all.

INFO Looking for your Tessel...
INFO Connected to Tessel-02A338563F88.

and Nothing from thereā€¦

I just need to make sure that I can communicate with the board at all.
I am using root to makes sure that there are no permissions that will prevents me for connecting the board using USB

Is there a DEBUG that I can use and see what is going on and why I am NOT able to communicate with the board at all.
I did managed to Authorized the board and I do get the Board Name every time I run a t2-cli command.

Please advise I do want to be able to work with it and communicate with the board using node.js running Java Scripts.
Is there something that I am doing wrong here?
Do I need to do something that I missed out?
Will be happy for any assistance and directions on how to be able to work with the Tessel 2 board and move forward to the next step of working with the modules that I can connect to it.

Thanks for your help

I was able to resolve the issue and Now can program Tessel 2 as intended.
I have not had any issues since.