Human Static Presence Module Lite not working

I have built 3 sensors with the presence detection lite modules and XIAO esp32c3 and configured them using the home assistant instructions. One of them works perfectly, the other two also worked at first, but then suddenly stopped sending data to home assistant. Unfortunately, I can’t get it to work again by unplugging and plugging in the 5v supply for the sensor. It would be great if there was a solution to the problem.
Thanks in advance.

Hello, from your description it should be a problem with the radar after a long period of work, can I know roughly how long the work lasted before the problem occurred? Is the radar able to see the information reported by the radar in the serial port if it is not connected to HomeAssistant? Or has it become completely useless?

the radar only worked for a few minutes before the problem occured. I don’t get any information from the radar in the serial port in arduino IDE. In the ESPhome log, information is displayed occasionally if I replug the 5V supply to the radar, but it is not “real” data (the values are always the same and have nothing to do with reality). So the radars have become completely useless.

Here is a picture from the ESP home log:

I have connected the radars with a uart to usb device to the upper computer as described in the instructions. There I also get no signal. It surely is not acceptable that two sensors no longer work after a very short time. It would be really great if there was a solution to the problem.

I’m having a similar issue. Data was flowing fine and getting valid readings in Home assistant and then it just stopped. I have sniffed the serial line and get the following output:

[Debug]Assert failed: C:\Users\djzr5\Desktop\work\sy110_f415\App

We will find such a situation in the actual testing process. It is the first time when powering up with XIAO ESP32C3, the radar may not start reading smoothly. At this time, you just need to disconnect the 5V power supply cable connecting the radar to XIAO, and then reconnect it to resume the use. ESPHome is able to work with the XIAO and radar for a long time if the XIAO is not powered up.

I have disconnected and connected the 5V supply several times, but the sensor still does not work. Unfortunately this is not the solution to the problem.

Same here. I disconnect the 5V and once I reconnect I get a few hex codes and then this error each time: [Debug]Assert failed: C:\Users\djzr5\Desktop\work\sy110_f415\App

Hey Tech-Rat,
do you also get this warnung when installing the firmware to esp32?

Nope, I am however using an ESP8266 if that makes a difference.

Have you tried to plug your module into a FTDI/UART device to see what the output looks like?
With out the ESP being involved.

Yes, I connected the sensors with an uart to USB device to my PC, ut I don’t receive any data there either, neither with the upper Computer software nor in Arduino IDE. Are your sensors working in the meantime?

I’ve sent you a mail.

Not sure why the email didn’t make it.

No, my sensor doesn’t work with any application.
It outputs a handful of hex numbers and then this error string:
[Debug]Assert failed: C:\Users\djzr5\Desktop\work\sy110_f415\Ap

No data is output until I power cycle it again.

This is a warning message, it will not affect the operation of the program, please do not worry

What can be determined at this time is that the radar is not getting normal data upload information after the XIAO is re-powered. At this point, you need to disconnect the power connection cable between XIAO and the radar, then reconnect it and the radar will work properly. If the XIAO is disconnected again, then the fault will reappear. Please wait a moment, our engineers are scheduling to solve this problem and will update the program later.

Hi Citric,
Thank you for the info. Unfortunately - in my case at least - disconnecting and connecting the 5V supply to the sensor while the XIAO is running does not solve the problem. Like I previously stated, I did this several times already and I still receive no data from the sensor

If this does not make the radar work properly, perhaps you should contact our technical support team and let them help you identify the problem and provide a solution. Thank you for your support and cooperation.


Ive just received the above modules from you and have the same problems, interrupting the 5v only very occasionally works.
What have the Tech Team come up with?

To everyone who is concerned about this issue:
We found this problem is a communication problem between radar and XIAO ESP32C3, you can solve this problem by modifying the TX RX interface, the new connection method is TX to GPIO5 (D3) and RX to GPIO4 (D2). Also please remember re-download the source code on github in step5 and update the yaml file. :grinning: