HiJack doesn't work on iPad 2

I received my HiJack a few days ago, and it works great with my iPhone 4.

But I’ve only been able to get it to work once or twice with my iPad 2. I’m just using a potentiometer with it, and the HiJack app from the App Store (oscilloscope). Sometimes it will read for a few seconds, and then stop. And other times I can’t get it to get a reading at all on my iPad.

Is there something very different about the iPad 2 that makes the HiJack not work well. Again, it works great on my iPhone 4.

Dear customer,

Thanks for your feedback. We would mind it.

Best regards,


So why doesn’t the HiJack work with the iPad 2? You didn’t answer the question.

hi sir, actully, we have tested the hijack with ipad2, it works well( as the wiki of hijack). if the one in your hand did not work with ipad2, i think there may be something wrong in the audio connecting. you can try to look for a 4-pin Headset extension cord and try again . if it still not works with you ipad2 and you need a replacement, please sent me message.

I am getting exactly the same problem here, works perfectly on my iPhone but not on my iPad 2, same symptoms as described above. Please offer a solution URGENTLY!

I have tried you solution of using an extension lead from iPAD2 to HiJack and I get exactly the same problem, I suggest you check that your version works with iPAD as mine does not, it does however work with iPhone.

I generally use my HiJack on an iPhone, but just tried it on several devices because of a question I got. In all cases, I tried both the free HiJack Oscilloscope app and techBASIC. The results were the same with both applications, so I think this is a hardware issue.

iPhone 4: Worked
iPhone 4 (different physical device): Worked
iPad 1: Did not work
iPad 2: Did not work
iPad 3: Did not work

Has anyone had success with the iPad? Did the extension cable idea work?

A quick follow-up: I tried a cable extender that I got from Radio Shack. This did not help at all. It made a very poor connection to the iPad–even plugging earbuds into the extender resulted in lots of static until I pulled the plug out about 1mm from the iPad. While this concept may be sound, I would not recommend getting the cable extender from Radio Shack.

My next attempt will be with an Apple-manufactured plug. I’ve sacrificed an old pair of ear buds…

As an app developer, I have on hand iPhones 4, 4s, and iPads 1,2,3

So far, my HiJack does not work properly on the iPad1 and 3. I will test the others shortly. I get junk signals, even when applying a simple 1.5v DC signal.

Alas, I’m not getting consistent HiJack hardware readouts even on my iPhone 4s. Very discouraging, as that is why I bought techBasic. I really don’t know if the HiJack units they are shipping are defective or not, but I’m finding them useless so far.

When I apply a steady 1.5VDC signal, I would expect a steady output of about 127. Instead, it varies every reading, sometimes 254, sometimes 120, sometimes 80, or 72. No consistency at all. I have no clue as to what it is reading.

I tried wiring HiJack to a connector from an Apple-manufactired earbud, but had no luck. If you want to try it yourself, here are the details. If anyone sees something I did wrong, please let me know.

  1. Stripping the white insulation from the earbud cable, I found 6 conductors:

    1. Green connects to the right speaker, which is the tip of the headphone jack.
    2. Red connects to the left speaker, which is the connection next to the tip on the headphone jack.
    3. The fat multicolored wire is actually two conductors. The thin multicolored wires surround a white wire. The white wire connects to the microphone, which is the connection farthest from the tip on the headphone jack.
    4. The multicolored wires wrapped around the white wire and the two copper colored wires are all ground, which is the connection between left and microphone on the headphone jack.

The wires were too fine to strip. I soldered them to 22 gage wire, which melted the insulation and gave a good connection. All ground wires were soldered to a single connector.

All wires but ground were plugged into the female header on the HiJack device. Ground was plugged into ground on the breadboard circuit. I also tried connection ground directly to the HiJack headphone jack.

Connecting the iPhone using the jack on the HiJack device still worked properly. I checked for shorts and good connections on the earbuds, and everything looked fine, but all I got was a steady signal–turning the pot did not vary the reading.

OK, success.

I discussed this issue via email with one of the HiJack designers. I’d be delighted if he jumps in, but I won’t post names without his permission.

His suspicion was that some change in the iPad’s hardware or software (perhaps as a result of the concern over hearing loss from ear buds?) might have lowered the power output so much that HiJack does’t get enough power on some devices. Checking this, the voltage drop across VCC to GND was the expected 2.75V on my iPhone 4, but only 0.87V on my iPad 3.

(Of course, I did turn the sound volume all the way up. That’s necessary to get the most power through the headphone. Be sure and try that first!)

I asked if I could supply power externally, and was told that might work, but I was strongly cautioned not to exceed the 2.75V design limit for the voltage. I used a couple of resistors to drop the voltage from 2 AA batteries to 2.7V and applied this across VCC-GND in a potentiometer based circuit. Success!

Here’s a photo:

So, it appears that many of the problems may be related to lack of power. Supplying external power to the circuit corrects the issue–but I have not exceeded 2.75V, and again, was sternly cautioned not to go much above this.

Please share your experiences, I’d like to hear if other people have success, too.

I too have just received the Hijack unit and cannot get it to work with my iPad2 nor iPhone4. I have tried the Hijack oscilloscope app and techBasic. The oscilloscope only gives random readings and doesnt even progress horizontally with a smooth speed. With Hijack.bas I get largely no reading but occassionally a horizontal reading just above 150.

I have the volumes on both devices set to full and have reprogrammed using with the USB adaptor just in case. The reprogramming works. I have also measured a voltage of 1.5V accross the Hijack GND and VCC pins when the code is running. This drops when I connect a 10K resistor across the supply rails. I have tried shorting the analogue sense pin to GND then VCC but still either get no reading or random waveforms, depending on the application used.

Should I be sending these units back for a refund or is there something that can be done.


The iPhone 4s, like the recent iPads, seems to deliver less power to the headphone power. As with the iPads, supplying external power solves the problem nicely.

Of course, be sure you have the sound volume turned all the way up before resorting to an external power source. :slight_smile:

well I have an iPhone 4 and one of the first iPad2s so I can assume that the Hijack doesnt work as stated can I? Very disapointing…

Does anyone have a design for an external supply circuit?

Re: Request for circuit to supply power:

I had good luck just using a couple of resistors to drop 3V from a pair of batteries to 2.75V. I used a 400 ohm and 2.7K ohm resistor in series across the batteries, drawing power off of the 2.7K ohm resistor. There’s a photo of the circuit in an earlier post.

The problem here seems to be a change in the power available from Apple’s headphone jack, not any deficiency in the HiJack device itself. The older iPhones simply supply more power. With the iPhone 4s and all of the iPads I’ve tried, you need an external power supply.

It seems to me that a power supply based on a coin cell battery should be easy enough to build, too. This would easily fit on the small daughter board that plugs directly into the HiJack board, maintaining the small size. I’m going to order some parts and build one, but if anyone beats me to it, be sure and post the results.

I have the same problems for 3G, 4S and iPad2. Do you solve the problem? Or the only way is to request the hardware replacement?


So, it appears that many of the problems may be related to lack of power. Supplying external power to the circuit corrects the issue–but I have not exceeded 2.75V, and again, was sternly cautioned not to go much above this.

Please share your experiences, I’d like to hear if other people have success, too.

Very useful information. Hope this could be written into FAQ.

By the way, why not tune the volume via application into maximum level instead of adding additional power supply?