H68K unable to install Home Assistant

Hi, I’ve followed the guide at Building a smart home control centre around Home Assistant | Seeed Studio Wiki
and when I pull image homeassistant/qemuarm-64-homeassistant:latest
I get this error:
failed to register layer: error creating overlay mount to /opt/docker/overlay2/7da6e72785f083788b274a46242971120631a4d4e2651/merged: too many levels of symbolic links

any ideas on how to fix this?


Has anyone successfully deployed home assistant?

Maybe you can try pulling another version of home assistant instead of the latest one.

Hi, Thank you for your reply.

I’ve tried different versions instead of the latest and also tried different images and I still get the same error message.


Please check if you have allocate more space to Docker?

Yes I did that previously.

In support have you tried it yourself to see if it’s an issue?

This error can be caused by having too many symbolic links on the file system. This can happen in nested Docker containers or on systems that have been in use for a long time.

To resolve this issue, you can try cleaning up symbolic links on your system or using a different Docker storage driver. Here are some steps that may be helpful:

  1. Clean up symbolic links

You can try using the find command to locate and remove excessive symbolic links. For example:

$ sudo find / -type l -delete

This will search for and remove all symbolic links throughout your file system. Note that this may take some time.

  1. Use a different storage driver

If cleaning up symbolic links doesn’t work, you can try using a different Docker storage driver, such as “mmcblk0p3”. These storage drivers do not use the “overlay2” file system and may not encounter similar issues.

As for how to switch storage, the Wiki also has guidance on this.

After this, restart the Docker service and H68K to apply the changes.

1 Like

Thank you very much for the information. I will give it a try.