Grove Shield for Arduino Nano v1.0 can it be used with a Nano RP2040

Hi, I bought a grove shield for Arduino Nano v1.0. I wanted to use it with a Arduino Nano Connect RP2040.
I experienced that when I mount the Arduino Nano Connect to the shield, the Nano is losing the ability to create a USB serial port. When I take the Nano Connect RP2040 off the grove shield the Nano is again able to establish a USB serial connection with a host PC.

Yet it is eight days ago that I created my post. No reaction at all! Why?

I have the same problem, when the RP2040 Connect is connected to the Grove Shield for Nano it loses/can not establish USB connection to PC.

I could resolve the problem:
The schematics displayed here Grove Shield for Arduino Nano - Seeed Wiki
shows a connection between the RST - RST pins.
If you remove that connection, the Grove Nano shield works fine with RP2040 Connect board.

I removed the connection by drilling a small hole directly opposite the middle jumper of the 3.3/5V switch. Be careful not to cut the connections of the 3.3/5V switch on the other side of the board:

Here is a picture of my drilled hole:

@Bodobolero. Thank you for your response and the solution. I go to drill the hole tomorrow. Then sure go to check the result.

Note that I used the newer Model with the 3,3/5v switch.

I have version 1.0 of the board without a switch.
This morning I drilled a hole in my shield, but not totally through. It worked out OK
Hole drilled.
Next I mounted an Arduino Nano Connect RP2040 onto the shield and connected a M5Stack 3-port I2C hub to the I2C connector of the shield. Onto the I2C hub I connected a TMP117 temperature sensor.
TMP117 sensor connected to Arduino Nano Connect

I loaded an example sketch from Adafruit. I modified it to print only to the IDE Monitor window. The sketch works OK. Conclusion: for me the modification of the shield works! Again thanks @Bodobolero.

P.S.: when the Arduino IDE (v1.8.19 MS Windows 11) finished the build, now appears for a few moments a popup window of the MS Windows File Explorer, showing the drive of the Arduino Nano Connect. (when the IDE is flashing the sketch to the microcontroller.

Thank you. That modification worked for me as well. My NANO RP2040 now works with the shield: