Failing to program the xiao BLE SoC via the nRF_DK board + XIAO expansion board

I’m trying to program the Xiao BLE device, while mounted on the XIAO expansion board, using the nRF52840 DK board.
I’ve connected the SWDIO, SWDCLK, VTG (to 3v3) and GND DETECT (to GND)
I’m using windows 11, and the latest nRF connect Application + Programmer app.
I press reset twice on the XIAO BLE, to enter boot loader mode.
I select the “XIAO nRF52840 Sense” device, but the programmer fails to detect it

“Unsupported device. The detected device could not be recognized as neither JLink device nor Nordic USB device.”


Can anyone assist in allowing me to program the XIAO BLE Sense via nRF programmer?

Hi, doesn’t look connected properly, look at what I have…

switch to the top row of pins and swap the red (GND) and Blue (3v3)wires. Your SWCLK is Yellow and data is green AOK,

PJ , thanks for your answer.
I have double checked the 3v3 and GND signals on the XIAO expansion board, and they are OK.
I even tried to use the VDD–>3v3 instead of VTG–>3v3, and also tried GND–>GND instead of
“GND detect”–>GND.
nothing worked.
I wonder:

  1. did you need to connect the RST pin to the JLINK, to make it be able to identify the XIAO?
  2. are the connections marked in yellow necessary?

this solved the issue.

1 Like