Esp32c3 seed studio STUCK IN DEEP SLEEP mode

I need help about esp32c3 stuck in deep sleep mode because my error in sketch arduino ide where i put it in deep sleep at the beginning.
In this wy the esp32c3 is not reachable from serial…
Do you have any idea how to solve,it?
I tried to start keep hold down boot mode and I can see a new usb port but when I tey to upload a new sketch it give me an error.

Hi Size:
After entering deep sleep mode, the XIAO’s port will disappear and you’ll need to wake it up to see its port number again.Activating boot mode did not solve the problem, and he was still in a deep sleep. In the program, we are using a D1 low level to wake up. This means that we can connect a button to pin D1 and the XIAO will wake up when we press the button.
(Currently the XIAO ESP32C3 only supports GPIO wake-up, and the only pins that support wake-up are D0~D3. This program may not work on other pins.)


1 Like

I am also having the same problem and grounding the D1 does not help either.
Not an expert, but I suspect the problem is the Example version of Deep Sleep with 5 second cycle.

So I tried the following:
Compiling the Deep Sleep with an empty sketch (setup() and loop() with nothing in it) does not get a chance to build and upload with in the 5 second window that Deep Sleep is running with.

Is there any workaround?

Please help.

I understand that your situation is that when XIAO ESP32C3 is in deep sleep, you cannot upload from Arduino IDE.
This can be uploaded by starting the ESP32C3 in bootloader mode.

However, there are some caveats.
Depending on the I/O pin connections, the device may not enter bootloader mode.

Please check these pins.
D9 … disconnected
D8 … add a pullup resistor

Thanks Takashi:
How do I start ESP32C3 in bootloader mode?
Appreciate your help.

Please look here.

I have this same problem

Hello all,
I have found that if you bomb the flash and Do notice that because of reliability issues, if no valid flash image is detected the RTC watchdog triggers (if memory serves) once every five seconds or so, re-initializing the USB peripheral; that can make getting the first program in there a bit tricky. If you want that to work for sure, pull GPIO9 down on reset; that puts the chip into download mode and stops the reset loop.

GL :slight_smile: PJ :santa: :+1:

thanks, i was able to break out, by leaving unplugged all day and MAKE SURE to hold down boot button on first connect to electric… i was afraid i was going to have to remember how to do the samd unbrick procedure with two Expansion Boards