Esp32c3 mmwave lite won't work


I recently bought a ESP32C3 and mmwave lite sensor.

Connected to 5v GND and D6 D7 according to the guide here and flashed the code from the github page (Part 1 and 3)

In Home Assistant I get the sensor and it shows 35 entities most are state unknown.

The lightning switch is off and when switching on it goes back to off immediately.

The log shows no sensor data.

I tried using D0 and D1 and same results, also swapped TX and RX wires without luck.

Any help please?

Been playing with it, coping everything again and still no luck.

No one else with same problem that can help me out?

You can put the D6 and D7 for D2 and D3, specific operation see Pin Multiplexing on Seeed Studio XIAO ESP32C3 | Seeed Studio Wiki

Can’t find D2 or D3 on that page though tried it, soldered wires to D2 and D3, changed code and after upload still nothing unfortunately.

I know this isn’t much help but i bought 2 lots.
1 ran for about 6hrs and the other for about 10mins then packed up.
There are other topics about this here and even a mention on the homeassistant forum.
Im thinking a bad batch or their just not up to the job.

I bought directly from seeed studio, I will contact them and see what they know…

If bought from aliexpress I can understand it’s a bad batch