Greetings, everyone.
Has anyone tried implementing RS485 with this gateway?

We have been trying to without success until this moment. On the gateway, we have uart tx pin as 17, and rx pin as 18. We can also see the orange led flashing, that indicates that stuff is being written to the uart input. Nevertheless, we have no output on either pins A or B when we do a ModBus Request.
We checked by both, collecting the error messages of Modbus when a sensor is connected (Connection timed out), and by scoping the bus lines with an oscilloscope during runtime.
(We are using ModbusMaster.h referenced on the official Arduino page, which we were perfectly able to use with other RS485 transceivers)

We tried setting DE to high when serial->write operations occur to enable the driver, and to low when serial->read occurs, we tested opposite tx and rx pins, all without success. We are at a bit of a loss, and the documentation for the TDH541S485H transceiver is almost non existant.

Waiting patiently for any feedback you might be able to give us.

It works with eModbus library and below pins. RTU04example sample is a good starting point.

#define RXPIN GPIO_NUM_18
#define TXPIN GPIO_NUM_17

Thanks. That did the trick. I was missing the RTS Pin for half-duplex control in the library I was using.