DSO Quad engineering sample bug and firmware upgration

Super ! How long will it take to start shiping ? 1 week ? :question:

I have been workin on a PC clent to work woth the Quad, but as Benf pointed out it is not going to be easy to squeeze all that information into the paultry 2 meg of disk space the quad has. I was thinking about perhaps a binary file. Not so easy on the eye but more compact.

You can track and DL my clent here


as you can see i am planning on at some time using it with 4 inputs and have already coded the waveform viewer and I2C and UART decoders.

All i need now is my Quad to arrive and someone to code up the export

Cheers Pete.

You may want to preview the following video to more quickly use the Quad upon it’s arrival.


Today I appear to have broken my Quad (engineering version HW v2.2) while installing the newer firmware. I think that the FPGA update got me because that update reports completed now that the Quad never completes boot-up (had to video the start-up screen and then frame step the video to find that very quick flash message “FPGA Update Successful”). With the previous versions you could always hold the right arrow key and power up to USB drive only, to revert back to previous software. After this problem, that USB drive only feature no longer works. So now that I am unable to access the USB drive, I am also unable to restore back to the previous version because I can’t change the files on the USB drive. :astonished:

you means you can not access to the USB disk only feature after updated the FPGA ? would you pls sent me a email to descrip the detail with some pictures ? thanks …

Yeah I got mine finally it is working and looks like a great start. The usb disk for updating is a lose for me because it does not work with Linux or Mac os which are all I have easy to use. From what I can see it should not be hard to fix it, but this needs to be fixed. Is there an open source source pool for building this with gcc available? Two days of using this with the current UI and I am getting ready to change some things. There is much that needs to be done.


We too have a lot of trouble updating the F/W.
When we tried to copy the file, 1 by 1, to the USB disk, it sometimes would not reset. We had to delete that erroneous file and recopying it multiple time.

After upgrade (SYS1.34 AND APP2.32) I cannot calibrate due to “parameters version error”.

I recognized that the scaling of the between 1V and 0.5V resolution is somehow strange. See the pictures attached. The square wave was generated using the internal function generator. I have the latest firmware uploaded.

I am using DS203 and SYS ver 1.51, APP ver 2.52.
Signal 8 MHz:

FRQ: show it as 8 kHz (needed “MHz”)
CIR: 0.0124 us (really 1/8MHz = 0.124 us)

500 kHz showed as 500 Hz (from internal signal generator):

FRQ: show it as 500 Hz (needed “kHz”)
CIR: 2 us (it is correct)

Signals from 0 to 999 Hz it showed correctly, as Hz
Signals from 1 to 999 kHz it showed as Hz
Signals under 1 MHz it showed as kHz

Hello, :slight_smile:

I don’t know if the error mentionned by Sergey82K has been fixed, but i have the same error on my DSO203. The frequency seems to be measured correctly but the measure (Hz or KHz or MHz) is not displayed correctly.

Hardware ver 2.60
Serial no 223D70DA
SYS ver 1.51
APP ver 2.52

Here are some screenshots :
10Hz -> 10.03Hz -> It seems to be correct.

100Hz -> 100.4Hz -> It seems to be correct.

1000Hz -> 1.007KC -> If KC means KHz, It seems to be correct.

10000Hz -> 10.03Hz -> It is wrong, it should be 10.03Khz or maybe 10.03KC.

100000Hz -> 104.7Hz -> It is wrong, it should be 104.7Khz or maybe 104.7KC.

500000Hz -> 546.7Hz -> It is wrong, it should be 546.7Khz or maybe 546.7KC.

1000000Hz -> 1.169KC -> It is wrong, it should be 1.169Mhz or maybe 1.169MC.

If you have a fix for this, please let me know.


You can try this one: viewtopic.php?f=22&t=2957


Does the signal look that bad already at 1MHz? The author of this video say it fairly good to 5MHz:



Some peoples said’s that internal signal generator has bad signal form on more 1 MHz. If You use internal signal generator for tests wave form over 1 MHz may be You see bad signal from internal generator.
I do not have good external signal generator or oscilloscope for tests :frowning:

I tried to sample analog composite video signal from digital photo camera: youtu.be/I1EYZJEZD2A

Thanks for the reply and video. So you think RemiD was using the internal signal generator in the above pictures?


No, on screenshot above the internal signal generator tuned to 1 kHz.
May be on screenshot not square waveform, may be some digital signal.

My oscilloscope with internal generator tuned to 8MHz (square form):


Some other my screenshots here

Thanks for the screen shots.


pmos69>>Thanks for the link, :slight_smile:
I want to update the firmware of my DSO203, is there a tutorial to know how to proceed ?

Dan13>>No the signal i have measured was from an external frequency generator.
However, this frequency generator may be of poor quality. I don’t know.

Thanks for the reply, Remi.

ESP and Hugeman,

Please can you tell me what the HW difference is between the engineering samples and the later ones? I would like to get the community open-source SYS and APP (and jpa’s Pawn!) to run on my engineering sample to the degree it is possible.