DSO Nano V3 will not upgrade

I just got the DSO Nano from ADAFruit. Found the upgrade instructions. When pressing the Down and power keys it states
Serial DDCC8AE6 Licence 787B77A0
Device Firmware Upgrade V3.26D

I’m using a Windows 8 pc.
I got a firmware.zip file from the DSO wiki
and it’s contents were:

I copied the first file to the Nano’s virtual drive and in a second or two it said .rdy. Then when I copied the second file the virtual drive closed on my Windows PC and never reopened in over several minutes.

On power up the nano shows white screen with upside down and reversed Seed Studio in Black letters.

That screen flickers.

I tried to do the process again several times but with no luck.

What can I do to get the Nano back to working condition. It was working before tried to upgrade the software.

Dale Eason

You will have to install the 4.22 firmware which is the only one that supports this model. (FAQ viewtopic.php?f=22&t=4227)

The 4.22 hex file is included in the file posted in viewtopic.php?p=18234#p18234

Thank you so much. I think I found the file in a DS201V4.22\IAR V6 Proj\Exe. I installed the 201V4_22.hex and I have it working again. Is that the only file I need to install from that directory?

Yes, the one file contains the whole firmware.