DSO Nano V3 purple Data trace & saving files?

I can scroll down to EX but then I need to select either:

  • Ext Refn
  • Ext Posi

If I select Ext Refn then I can use the arrows to go though the displays:

If I select Ext Posi, then nothing happens

I cannot understand how to record a trace and load it.

Are you using a Nano V3??

Anyone found a fix for this?

It goes away after you save a new data file. Scroll down to ex and go left or right till you have selected off it will not show the trace again till you scroll over back to data. Its the factory sample file.

Thanks for the help, but I do not have “off” as an option on my Nano V3 … so I always have some annoying trace to confuse the display…

I’m very disappointed with this device…

When you turn on your nano what firmware number shows up maybe needs a reflash i have all the factory firmware just need to know what yours is sounds like maybe it has a demo version i had that happen to me when a flashed a bunk firmware. Does your nano have white buttons and were did you get it.

I don’t have it in front of me, but I believe it says version 4.0 on startup.

This is the one I bought: http://www.antratek.com/dso-nano-v3

white buttons, no sd card slot, probes of poor quality, and bad contact at prob plug…

If you have other firmware, I’d be interested.

Do you work at Seedstudio? How do you get firmware, then?


No just user like you if you look at the most recent posts i just posted under “another firmware question” i attached the v3 firmware 4.21 its the most recent. There were a few other updates after 4.0 but I think you should be able to go right to 4.21 I also attached the update v3 user manual that has the upgrade how too

Thanks! I downloaded it and will try to install it when I am home and have the nano in front of me.

Is there much chance of killing the nano with a firmware upgrade?

I really appreciate your help!


I had mine bricked and was able to bring it back with a reflash so should be no worries. The only thing we may have to do is try and install the versions in order of there release but i dont see that being a problem just jumping to the most recent. When you start it up holding the down on the key pad it should go into boot loader screen what number is on that screen should be 3.26d ?

I did the test and saw the the firmware is given as 3.22A !

Which I guess explains something?

Where are the instructions for uploading the firmware, please?

Thanks for all this help!

Well I did the upgrade, and now all I get is the black screen with the labels, no trace display and no controls work!

It’s dead…

Where can I get the older firmware, please?

Try them in the order i posted them starting with 4 then 411 and finally 420 only install one at a time then try it and if it dont work on to the next im going to add one last file try this one first acually its the ben f for the 3.22 boot loader it will be the best for functionality if it will take if not then try the factory ones. The files with 2 files need to both be installed one after another and make sure the file changes to the dry extension. Dont stress its will be solved :slight_smile:
BenF364_LIB353-1.zip (49.6 KB)
201V4_20.zip (39.3 KB)
201V4-11.zip (31.5 KB)
DS201V4.zip (41.2 KB)


You are the MAN!!!

The BenF firmware seems to work! The trace is stable, and the buttons all work.

I’ll try some measurement later and let you know!

It’s been quite a struggle, but it’s starting to feel worth it :slight_smile:

Thanks so much!

On the benf there are 2 files app and lib did you get them both on and you have to do both one at a time some have had problems trying to highlight both at the same time

I am running linux on my pc and am an IT expert :wink:

I put the Benf files onto the Nano one at a time and it worked immediately, or at least the buttons work anyway.

The BenF seems to work fine on the Nano V3, but still no measurement test for lack of time. The interface looks a lot cleaner and the trace is sharper.

I’ll let you know any results!

Thanks again!

I’ve had the DSO Nano for a few weeks now and am a little disappointed with it. I’ve had the same problems described in this post. I tried the firmware upgrade to 411 and 420, of which neither functioned (unit initializes and screen shows a static image with menu on the right-hand side but no buttons work and no trace drawn). The BenF firmware doesn’t even show anything on the screen. When I power on my unit it shows DS201+ APP Ver4.00. When powering on while holding down it shows: Device Firmware Upgrade V3.22A.

Can anyone help me with this one???

Thanks in advance!


I am no expert, but I managed to follow the firmware upgrade instructions and can now use the BenF firmware given in the post of Sat Jul 13, 2013 4:13 pm in this thread.

Please try that and let us know.

ps. I did all my upgrading from a Linux Ubuntu pc, maybe that has some advantage?


Hello, but with BenF firmware It is no ability to use Internal memory to store anything, I see “NO CARD” so can you help me?
Thank you!

Did you try to connect to a Linux PC? Did you read the firmware upgrade page on this forum?

Even with the original firmware I could put files on the nano.

I’m happy TT o try to help, but please try to explain better we what you did and on what PC… Etc


to get rid of purple sinewave, hightlight EX press left arrow until it says Off, press top right key to save commands, hold it in then press again to save it, bottom M key save files.

Hi There…you have 3 options, whatever will work

1 benf program
2 copy the 2 hex files
3 use original prog, see my other messages for info, ver 4.22 at moment.

G4VVQ Fred