Display troubles


I received my brand new DSO nano and, excited, started a few jobs with it. It worked really nice.
But from time to time, when I switched it on, I got a blank display or a crappy one. Finally it happened quite often and decided to update the firmware to the latest BenF one. Again, it worked nice. But again, quite often (I would say 4 times on 5), I got a crappy display :

  • all the lines are interrupted (like dotted line)
  • the display is mirroroed botton/up and left/right.
    I join a picture of the welcome screen and the work screen.

I’ve the feeling that this could be related to the battery charge. Indeed it does not happen just after the charge. Let’s say, about one hour later.

Any idea about what’s happening in that case ? Could it be a defect, and I should return the device ?
Does it happen to others ?

Thanks for any help.

Didn’t get your products, we are not sure what is the troubles with the DSO nano, but I have feedback to our QC.
You can also contact our QC. E-mail:kevin.hai@seeedstudio.com

Best regards,

Thanks Deray.

I took contact with Kevin and got the final answer :

Is there any way to use it, at least ? Even in a reduced configuration. I figure out I’m not the only one to get this trouble :cry:

Wow sorry to hear of your problem, I see others have it also, I have the previous unit, it has never displayed this issue with Benf or the original firmware. The Benf firmware is far more versatile and stable than the original on it, I would like to see “Fit mode” be selectable to manual V/div or Time/div, not just auto both. And it annoys it forgets your last settings when you turn it off. Other than it is a major
improvement and definitely doesnt cause screen malfunctions on version 1 DSO Nanos

If you dont need to the higher than 2Mhz frequency ranges I would consider sending it back and getting
the previous version if this problem is out of hand, or the newer one that is full touchscreen,
but it may have the bug also. Best hopes, Troy

imho, it looks like bad timings in lcd write functions. may be somewhere some delay needed.