Crazyradio PA usb not being recognised by any system

Hi Team,
Got this Crazyflie USB from Pakronics Australia -
It is not my first USB and I am familier how to use as well have been using them for a while. But this new one I think have some firmware or hardware issue as my PC (tried MAC/Windows) nothing seems to recognise it.
Unfortunately the device seems to be faulty for whatever reason. I’ve owned a couple of these devices before so I know how to troubleshoot them but I believe there might be a problem with the firmware.

I know the devices is getting power:

Checking the usb initialization I can see that it is being read so it again confirms power:

But scanning for attached usb devices shows nothing (where it definitely should):

Another scanning tool:


I even located the usb flashing software developed and used by bitcraze (developers of the crazy* software) but it still couldn’t detect it:

It’s also worth mentioning I’ve tried different ports, operating systems, laptop/desktop but still nothing sadly.

From my previous experience with this product, I believe there’s a problem with the firmware which I understand is no ones fault.

Since this model is faulty should I expect a replacement? I’d really appreciate your assistance.

Also please let me know if you need the complete output log of these scans and I’ll send them to you.
After rebooting I ran another system scan of it and as you can see from the screenshot it now is failing to read the device at all which supports my theory: