Confirm GrovePi+ works with Raspberry Pi 5?

Can anyone confirm that the GrovePi+ hat works with the new Raspberry Pi 5?

We are sorry to inform you that the GrovePi+ is not currently compatible with the latest Raspberry Pi Bookworm OS.

I can not get Raspberry Pi 5 to work with Grove Base Hat for Raspberry (SKU 103030275). Installation commands on the wiki (Grove Base Hat for Raspberry Pi | Seeed Studio Wiki) after
‘cd grove.py’ do not work. Please rectify or confirm that this HAT is not compatible with OS Bookworm.