Can't upload to Wio Terminal using Windows 10

I received my Wio Terminal yesterday. The default game on it ran without problems.
I installed the driver from here: and the device manager recognises the device correctly as “Seeeduino Wio Terminal bootloader” or “Seeeduino Wio Terminal”, depending on the mode of the Terminal.
When I try to upload the blink example to the correct COM-Port via the Arduino IDE 1.8.13 under windows 10 I get the following error:
at cc.arduino.packages.uploaders.SerialUploader.uploadUsingPreferences(
at cc.arduino.UploaderUtils.upload(
Caused by: Error touching serial port ‘COM11’.
at cc.arduino.packages.uploaders.SerialUploader.uploadUsingPreferences(
… 5 more
Caused by: jssc.SerialPortException: Port name - COM11; Method name - openPort(); Exception type - Port busy.
at jssc.SerialPort.openPort(
… 6 more

Using the switch to enter Bootloader mode causes this error after a very long upload time:
An error occurred while uploading the sketch
No device found on COM12

(note that COM12 is the correct COM-port)
When the Wio Terminal is connected to my PC in bootloader mode I am also unable to open a new explorer window or access any of the files on the “arduino” drive. The Wio seems to lock my PC unitl it is disconnected/reset. Only after disconnecting/resetting the Terminal all the actions complete.

I reinstalled my arduino IDE and rebooted my PC several times. I also tried other USB ports/cables on my PC.
The only way to upload a program to the Wio Terminal was to use another computer running MacOS, so it has to be a problem with my windows machine.
Is there an easy fix for my problem or has anyone had similar problems with their Wio Terminal?

Hi Simon,

just to be sure
you have SEEED SAMD boards installed in your Arduino IDE

reboot, connect wio terminal and upload blink ?

Hi BoRRoZ,
thank you for your reply.
Yes, I have “Seeed SAMD Boards” 1.7.9 installed and I am using the same upload settings as you are.
I am getting the same errors I described in my original post.

Did you try to programme any other boards?

I can program an Arduino Uno and Due without an issue. The only board I can’t program is the Wio Terminal.

And you can also program the WIO Terminal using other computer right?

Yes, exactly. I can program every board except the Wio Terminal from my main PC running windows 10.
I was able to program the Wio Terminal using another computer running MacOS.
I would like to be able to program the Wio Terminal from my windows 10 computer.

seems like the Windows computer Arduino IDE Issue, Can you try to uninstall Arduino IDE and clean all the Arduino related files from documents and AppData and install fresh from Arduino website.

Try connecting with the WIO off. Then switch it on in Boot Loader mode as described here:

You should see a disk drive mounted with some file in it.

At lease then you will know it is not an interface issue and the WIO is working

Once that is done try uploading again.


Hi Stuart,
As I described in my original post, when I connect the Wio in Bootloader mode I get the following error:
An error occurred while uploading the sketch
No device found on COM12

I can see the files but can’t access any of them. When I try to access the files my windows explorer locks up completely until I disconnect the Wio Terminal.


1-I would check if the connection is still open the moment you give the erase (or write) command.

2- try to create a folder on your desktop and unzip IN that folder the tools needed
then use powershell to give instructions

no guarantees :sweat_smile:

Are you using the same cable to connect to the mac and to the Windows machine? Without extensor or hubs.

Hi @Simon_K can you try this!

I am also having this same problem. All works fine with a Mac but with the Windows 10 machine, the upload fails when trying to open the port. I’ve tried two different Wio Terminals and two different Windows 10 systems (One of them I did a fresh install of Arduino). Both of the windows systems are running Arduino 1.8.13. It would be nice for this to be addressed ASAP. Also, the attempt to get board information via the menu works fine.

Also, I tried uploading (after selecting the correct port) when the system is in and out of the bootloader mode–still no luck. So, this solution does not work: Can't upload to Wio Terminal using Windows 10


Hi @bhclowers

I fixed the problem on my Windows 10 Machine by uninstalling a Program called „StableBit scanner“

I have not such program on my system. I’m still having this issue. Wish I knew even where to start.

@bhclowersAre you able see the wio terminal listed in the device manager!

Sorry for raising a dead thread, but I found a fix that might help anyone else with this problem:

If you slide the power switch down, it resets the microcontroller. Slide it down twice in quick succession to put the microcontroller into bootloader mode. This will cause a new serial port to enumerate on your computer. Select the new serial port in Arduino and upload the program. It should upload without any problems this time.


Hello Shawn,
I came across this thread trying to find a solution to a similar problem.
I have created an impulse using Edge Impulse Studio and download the Arduino sketch.
The target board is a WIO Terminal board.
The board works fine without any problems when using built in examples (e.g. LED blink etc, SEEED examples).
However, when I try to upload my custom impulse sketch on to the board, the uploading goes without any problems. However as soon as uploading is completed, the board disconnects from the computer and I get a message from Windows “USB device not recognized. The device may have malfunctioned blah blah…”.
At this point I cannot find the Wio device in my Arduino IDE at all, unless I boot the board back into bootloader mode by pressing the power button twice as mentioned by you.

However, on repeating compiling the EI impulse again, I get the same problem.

Stuck in a loop.

Any help would be appreciated.

Kind Regards


Hmm…I don’t remember seeing that problem. Can you get a serial terminal to work using Serial.begin(115200); and Serial.println(“some stuff”); in Arduino? You’re also welcome to try my code here ( that’s been modified from the Edge Impulse example (note that you’ll need to have an Edge Impulse library installed…I used a keyword spotting model for that particular program).