Can't connect on LAN on Mini Router/PC RPi CM4

I just received my Raspberry Pi CM4 mini-router and attempted to configure it. All was going great until I tried to change the default LAN interface IP address from to Afterwards, I was no longer able to access the device through LAN; indeed, I can’t ping it, I no longer get DHCP, nothing.

After exhausting my knowledge and options, I figured I would just re-flash it back to factory with the instructions found here:

After what appeared to be a successful flash, I tried starting over, but I still cannot get anything on the LAN port. I still don’t receive DHCP from it and setting a static IP doesn’t help either. I’m now at a loss on how to get back into this thing. Any ideas for me or do I now have a 2 hour old $149 paperweight? :frowning:

I connected my mini-router to a video output and received the following output from it. Connecting a keyboard to the router does cause it to show that a device was plugged in and recognized but it doesn’t appear to respond to the keyboard. The keyboard also has no lights on it (caps lock, num lock, etc).

I have the same problem and posted it here:

As I noted, the images broke when they switched to the new kernel. The last one that works for me is in folder 2022-02-28. It is really a shame that SEEED don’t actually check that the compiled images work or answer the forums for support.

So it appears to be a common problem and not related to anything specific that I did. What is weird is that my mini-router WAS working just fine right up until I hit “Save” the very first time. At first I chalked it up to changing the default LAN IP and just needing to IP my computer correctly to get back into it, but when that didn’t work, I figured I would reflash it to default it back to “factory”. And now I’m left with a non-working router. I received replies from their tech support but when I tried to reply back just this morning, I got a " Message blocked
Your message to has been blocked. See technical details below for more information." bounce back from them.

I would try re-flashing to factory image from 2022-02-28 release folder.
My router boots and works that way but over time will become outdated unless they fix this.

What’s the latest image that you’ve tried? I reflashed with 2022-05-02 and it didn’t work. I’ll try the latest one tonight if I can but if it doesn’t work I’ll do what you said. I wish I knew what version was on it when I received it because it did work for a very short time.

I tried the latest version available tonight (2022-05-05) and it changed nothing. I will try using the much older 2-28 release for now to see if I can get an actually working product at least. This is very frustrating and disappointing. All of my emails to their different tech support emails are also bouncing back to me being rejected as “spam” from their mail server.

So the good news is that there is a new release that apparently works: 2022-05-20 (kernel 5.4.194).
The bad news is that SEEED representatives have been completely silent and unavailable in this thread and at my other thread covering the same issue. MAYBE they payed attention or maybe I got lucky. If anyone is considering a new purchase, you should take this into consideration.

I’ve been procrastinating on trying the new release but plan to actually make it happen today. I’ve been following SEEED through both Discord and Github, as well as through email. I’m assuming this is you who posted it on Github, yes/no?

Good to know, that was not me and I was not aware of that avenue.

I’m returning my unit to Amazon while I can, lol. This company doesn’t provide support. Big red flag!!!

1 Like

Hi, may I ask what product issues do you have and how can I do to help you deal with it. I noticed you haven’t published any posts yet, what trouble can I help you with?