Cannot program Air602 WiFi Module

I get several Air602 WiFi Modules and Air602 WiFi Development Boards for testing.

I can program Air602 WiFi development board with LuaTools_1.5.7.

However, I cannot repeat the same thing on Air602 WiFi Module.

Here is my setup, I use Sparkfun 3.3V FTDI basic UART to connect to the UART pins of Air602. I tried powered directly from FTDI basic and externally from an Arduino 3.3V, no difference.

Air602 FTDI





ANT -> (external antenna)

RST -> (manual control)

First, the module didn’t respond to any AT commands, I tried both 115200 and 9600.

Then, I tried to use LuaTools_1.5.7 to program, but it ends only after two bars, see attachments. It never show "下载成功“.

After several tries, the module starts to spam CCCCCCCC in about 0.5s interval.

I tried LuaTools_1.5.7 again, still the same thing, it ends only after two bars, never finishes.

After some digging, I found official documents to tell me using SecureCRT to program the module.

I followed the instruction to program a FLS file, but it says "Xmodem operation was canceled by remote peer and then the module starts to spam JJJJJJJJJJJJ then CCCCCCCCCCCCC.

I never succeed one flash with Air602 WiFi module.

I tried AirM2M_Luat_V0010_W600T_USER.FLS, AirM2M_Luat_V0010_W600T_USER.img, AirM2M_Luat_V0011_W600T_USER.FLS

Please help me. It’s probably my setup has some issues, but I couldn’t figure where.

I found that the ANT pin needs to connect a π-type matching network for antenna matching.

In the test above, I directly use a u.FL 2.4GHz antenna connecting to ANT pin.

That’s probably the reason causing the unit not working properly.

I will try to utilize the antenna on the Air602 Dev Board and see if that works.

Update: I can program the Air602 WiFi Module with LuaTool (firmware AirM2M_Luat_V0011_W600T_USER.FLS), but the module does not respond to any AT commands.