Board Manager will not load in Arduino IDE

I came here to see if anyone else had a problem with the link to the board manager for the seeed Xiao. I see similar problems but not the same, so my question is not answered. I type in the link to the file json, and I get an error message that’s it fails to download. I go to the location where it’s supposed to be and the json file is empty, but the raw file and header are there. How can this work in Arduino IDE without this issue being solved? Forgive me if this is vague but I’m new and inexperienced. Just got the XIAO today and would like like to see something other the 2 small LED’s light up.

Tripple check the url and dont forget adding the coma’s also try to uninstall and reinstall arduino if nessesary

I’ve checked several times, and followed the link and it still says error unable to download from I may have an issue with the IDE because I also tried to install a board manager for the ESP32 and it gives an error about 4 pages long ending with protocol not defined. That’s a raw file, from looking at it, and I think it needs the definition to make it a Json, but I’m over my head on this, so I’m going to be looking at CircuitPython or some other way to get these to work. I have used it for a few projects on the Arduino and it’s worked as expected. i really wouldn’t expect reinstalling to work but if nothing else works I will.

It keeps your sketch files so i would uninstall and reinstall or try the new arduino 2.0 or a previous release it will work,you need to sit down and do it

I’ve kept poking at it, and I’m not sure what it was, but it seems it loaded and now I see the seeed boards, so now I’m going back to work on the ESP32. That’s the one I really want to work on. Thanks for your input, I’d given up, but now there’s hope.