BenF 3.x FW on new LCD driver devices [flick. screen solved]

Hi

I just bought me a DSO Nano V3.

I’m a previous owner of a v1 but since the USB connector fell off I thought I get a new one :slight_smile:

So to my problem, as far as I understand I need this firmware for my device. So I have it downloaded.

Some information:

Version shows V. 4.28.
Serial: E3CCCAD8
Licence: 340E242A

Device Firmware upgrade: V3.29D

But a problem arises when I put it in firmware mode by pressing arrow down and turning it on. The virtual disk appears only a few seconds, then it’s gone. Only shows up as a Removable Disk F: Tried several cables and several computers from Windows 7 to Windows 8. Same happens on every computer, so I’m kind of ruling out my computers.

Any ideas?

EDIT:!

Just for the heck of it, tried it on the second computer again, and to my suprise the virtual disk stayed.

So I got it upgraded. Do I understand it correctly if I only need the one hex file? BENF_P2.hex

Thanks for patched BenF. I just want to ask, why my 2gb SD card now detected as 32gb (official FW displayed it properly). Is this a bug or feature? Thanks. :slight_smile:

I also want to express my thanks to rimidalv007 for taking the time to make the BenF firmware work on latest hardware and sharing it here. THANK YOU!!!

I recommend updating the wiki to also point at this latest patched version.

I too wanted to thank you for your work, you have given meaning to my up-to-now useless Nano!

The source would be awesome, but still thanks for your work!

Thanks for your efforts in improving the BenF Firmware.

I’ve just found this forum after getting a Nano V3 fro Christmas.

I see it’s been asked before but I’ll ask again as there was no answer, will it ever be possible to save data to the internal memory of the V3 (without SD card)

I’ve updated it to 3.64 patch V2.

Thanks,
Phil

Hi there,

I would need help from the experts please.

I have bought just few days ago a DSO201 nano v1, serial: E3D0CEC7, Licence: 171B9CF7, DFU: 3.29D

I tried several times to upgrade the firmware with the file BenF_3.64APP_3.53LIB_patched_v2.zip but i always get an .err file after dropping the .hex on the DFU…

Can anybody help ? Is there another file I should try ?

Thank you very much for your help !!

Jerome

I fixed microsd slot problem, via hardware, applying a custom card slot over unpopulated pcb.
Images e reference in english on my site, i cannot post links in my first 24 hours of account life sorry.

https: // limon93.wordpress. com/2015 /05/22/ dso-nano-v3-micro-sd- card-diy-upgrade

Remove six spaces from the url to open it, tomorrow i’ll fix.
No SPAM.
No ADS exept wordpress ones.

Hi, new DSO 201 owner here trying to install the BenF firmware, unsuccessfully so far. It came with firmware 4.28.

In DFU mode, the screen reports:

            NiN

digital storage oscilloscope

Serial: DDDAB8BB License: 41BE9A7F
Device Firmware Upgrade: V3.29D
Please copy Hex or Bin file to
the DFU virtual USB disk.

I copy the BENF_P2.hex file from BenF_3.64APP_3.53LIB_patched_v2.zip to the device and I see it deactivate and come back, with now BENF_P2.RDY on it. Power cycle the device, and I’m back to the 4.28 version. It seems like the device thinks it has installed the new firmware, but not actually.

I have tried various other firmware versions. Every now and then it works correctly. At the moment I’m on firmware v4.30, but I have not yet managed to get the BenF version to install. Any ideas? Google led me here, and has found plenty of discussion of firmware install failures, but none quite like this.

In messing around with the device, I found a hardware information screen. Power up with the [-] and [M] buttons held down and I get a screen that looks like:

            NiN

digital storage oscilloscope

Hardware: Version 1.7B
MCU Type: STM32F103VB
LCM Ctrl: ILI_9341
USB Disk: Ext MSD Card

I haven’t seen this mentioned anywhere else, though it seems unlikely that I’d be the first to stumble upon it.

OK I have a DFu V3.29d Hardware v1.7B, MCUtype STM32F103VB, LCM Ctrl: ILI_9341 and seem to have every headache described in this thread.
I tried upgrading with the latest dfuse demo, but no devices show up. I tried installing from the 3.0.0 version, same problem. I tried doing drag-n-drop but the drive either disapeers or the attempt times out. I tried installing the driver over the defaulted on in windows (driver that came with the 3.0.0 version) but it always falls back to the windows driver.
I tried throwing dfu-util on two different linux based machines - I tried everything under the sun to get it to see the dfu devices with no luck.
I eventually found that on linux I could get the /dev/sd? to mount from root. I tried copying the two files in together, dismounted the partition, remounted and saw one reading RDY, the other reading ERR. I tried copying them one at a time - dismount/remount and saw RDY on each that way one at a time. I powered off and back on and had the white flashing screen.

I came to this thread and have tried again with the original two files twice (together and separate) and the patched version twice. I have tried grabbing a LIB301_APP311_2 suggested by one user, still white flashing. I tried grabbing DSO Nano 2.6 official firmware - still white flashing.

At this point I don’t care if I end up on some old version - can anyone tell me how to un-brick this thing please?

The dfu mode still comes up fine and the info mode still come up fine, and I can see the logo briefly before the flashing thing. Any help would be greatly appreciated.

OK, I finally got it. What I did that helped was that instead of keeping ‘My Computer’ open in windows explorer, I opened any other folder and set the left side to show folders and made sure computer was expanded there instead. (I suspected the regular behavior windows explorer would try to ‘read’ the DFU device which was confusing the thing and triggering the disconnect/reconnect behavior)

At that point I could see the DFU device connect without it immediately vanishing, copied the P2 over and it took in one shot.

SW

Just received the Nano V3 and I tried installing BenF 3.64 and it failed. I accidentally deleted the firmware V3.45D that came with the Nano V3. Is their a site where I can either get the BenF app and lib hex files that will work the scope, or at least get the V3.45D app and lib that came with it?

Thanks

Did you get it fixed?

Have you tried BenF_3.64APP_3.53LIB_patched_v2.zip from link in post#1?

Try attached BenF 3.64 v3 with minor hex error fixed for V3.45D. Original patch done by rimidalv007.

I bought a nano v3 when they were fist released some years ago,after mucking around installing Ben F files for months-coming back to forum many many times it worked BUT never would connect to the SD card - which I needed to save auto pattern files.
Found a “FIX” on this site,soldered PCB as instructed,sayonara Nano, chucked it in a box in disgust, its still there,I’m no tech so I should have left it alone I suppose.
Over the years I’ve cooled down,bought a Pico,which is top gear,but carrying a lap top etc is not really portable IMO,I’ve decided to risk my money and try again,are these devices able to be got working again?
I know they have onboard memory now-is it accessible with riminal’s firmware -I think it is?.
Its become difficult [for a non-nerd like me} to sort all the updates out,
I notice Seeed have taken a very backward stance in all this,maybe they can’t write code,or don’t want pay Ben any money?
AES in US sell what appears to be the same product -or a clone maybe foe US$125 I think but freight to Australia is shocking-I bought a $99 book from them -not large,about the size of a large magazine $110 US freight ,a big ask I reckon!
So,can I buy another V3 Nano and expect [if I can sort out all the files that have been updated] and expect it to work,and store and export files without throwing away more money?
Any contributions would be appreciated Thanks Baz

bazbroom,

I don’t know what your needs are so take what I say with grain of salt.

I know of 6 different versions DS201 in 3 physical forms on the market. Pictures here seeedstudio.com/wiki/DSO_Nano

These I know, maybe there are others…
Version 1. DS201/DSO Nano v1
Version 2. DS201/DSO Nano v2 old LCD
Version 3. DS201/DSO Nano v2 new LCD
Version 4. DS201/DSO Nano v3-external mSD slot
Version 5. DS201/DSO Nano v3-2MBytes built in memory
Version 6. DS201 PRO/DSO Nano v3-8MBytes built in memory

Depending what version you get will dictate if you can have a fully functional Benf 3.64 or not. Since Benf firmware was written for external MicroSD in mind and the old LCD, it will work on versions 1 and 2 just fine. Then you can load Benf 3.64 patched v3 on version 3 and 4, again fully functional. It will also run ok on 5 to 6 versions minus the Saving/Loading functionality. Some people did get Benf working fully on version 5 to 6, but it requires soldering in the external MicroSD slot/card.

I personally own the DSO Nano v2 old LCD with Electron 007 firmware and it works for me but I am droolling over DS203. Therefore I will recommend getting DS203/DSO QUAD hw v2.81+ and load Wildcat 6 on it.

Good luck.

P.S. If you do get the current version 5 then most likely it will have factory 4.30 firmware. It seems to work ok and does Loads/Saves files to built-in memory. I would NOT recommend the version 6 because the lack of firmware development.

Thank you for your reply,firstly re buying V 2/3/4 or whatever from Seeed seems to be a big chore,they have no stock of any Nano’ATM,even if the had,I don’t know if they could identify which version it was!
Mine “was” V3 with SD card loaded with BenF 3.64 etc and worked quite well ,with attenuater I read HT patterns in Auto ignition systems – but could not store or keep reference files that’s when I tried to get it to store files.The screen type I don’t remember but I did a lot of checking on this site - which is IMO a maze and hard to find my way around,I got here yesterday one way today by using the search engine ,weird!
To me 4 channel DSOs are overkill in motor diagnosis work, plus metal cases can be fatal in late 50kv ignition systems and for almost $200 for a Quad is overboard in my case. The latest Pico 2 channel are approx 80 pounds Sterling,peak voltage 100v. non auto ones can be used on cars with attenuaters as well,but are small and fast, but not a pocket size , need a laptop – and have good backing from the manufacturer .
Seeed leaves it to the users which I suppose that’s what is its reason for being sold,unfortunately its nice gadget,but it is in the realm of the clever few IMO.
Maybe Seeeds real interest is in Robots etc,shame really, Oh well I’ll check on a cheaper form of freight from USA,and think it over best wishes to all I then work out the pro’s and cons baz

I don’t know why Seeed don’t stock the cheapest v1 nano’s but they are still available elsewhere. It seems those have external sd card slot so most likely Benf 3.64 patched V3 would work and they are plastic. The button takes getting used to. This probably your best bet.

Do either the V2 or V3 files exist? When I try to download them, it reports file cannot be transferred… Still stuck with a brick… :cry:

Rimidalv007, the file LIB301_APP311_2.ZIP doesn’t appear to be active anymore (unable to deliver file)… anywhere else I should be looking? I’m still sitting here with a brick. (Serial B5DDCA09 License F6E6698C) (Yes, I got it from Ebay)… Unfortunately, it choked on BenF 3.45D. Neither is Motorpass’s BenF_3.64APP_3.53LIB_patched_v3.zip

gelfling6,

Did you make any progress getting Benf v3.64 installed on dfu 3.45d?

You tried > BenF_3.64APP_3.53LIB_patched_v3.zip ?