AWS SEEED IoT 1-Click Button not registering with WiFi via iOS app

We are a SAAS company that integrates video to corporate data. We are developing an AWS service integration based on the SEEED IoT 1-Click Button for a large US multi-site corporation (500+ sites ) for site security. We believe there is a market to supply this service to our remaining customers and are keen to move forward with the concept and beta trials.

Development** is not going well.** Of the 5 buttons we have tested, 4 are unable to connect to the WiFi. The mobile apps are frustratingly uncommunicative regarding this step and consequently we cannot determine what is at issue. Our latest attempt at our customer’s test lab has left them, and us, deeply concerned about the reliability of your product design.

We are attempting connections to a 2.4GHz wifi network running WPA-2 Personal authentication.

We have read and followed the directions for using the mobile apps (we have tried both iOS and Android versions). We are powering the devices via USB-C for development purposes and intend to use a battery when in the field.

The devices are flashing the appropriate codes throughout the process but fail the Wifi configuration step.

I have reviewed your forum entries and the AWS 1-Click forums to try to resolve this issue.

Can you help? Do you have debug program that I can run locally to track and resolve this issue? Or can you offer more insight on how to resolve this issue.

Hi @Guy_Bisson
What was your LED status and the wrong info indicated when you fail the wifi configuration steps?
I think you should check the router or change the network configuration at first.
And then try to get the OTA update.

Hello,
Throughout the phase where we were on the WIFI configuration page, the unit was flashing blue. There is no other LED code indicated by the unit. After several minutes of flashing, the units simply turned off.

There is no issue with the router. Every other device that I’ve connected to the network wireless has had no issue. This is not a router issue.

Recall, you can’t perform an OTA update without a network connection. I do, however, have a direct USB-C connection. It would be a shame if your design team did not have a means of leverage a direct connection…

Finally, and most importantly, we are planning to deploy these devices in our customer’s sites. We cannot and must not rely on changing a 3rd party’s network to allow for a basic wifi connectivity.

What other options should I consider?

I am having the same problem - is there a solution to debugging or connecting via USB?

Hi @Guy_Bisson @mmatta
Please check if the AWS app has been updated to the latest version.
Please provide AWS Button DSN to us, because DSN is related to software.

Downloaded iOS 1-click app version 1.4.4.0.0 last week direct from the app store.

P5SJVQ2003W1LD3H,
P5SJVQ20032BWG4F,
P5SJVQ2003QDFS5K,
P5SJVQ2003OOG7ML - This one is at our customer’s lab…

Hi @Guy_Bisson
We have checked your DSN, it is no problem.
So we only think that it may be a problem with wifi or buttons or a problem with APP.
Can you change the connection point, for example, use a hot spot?
You can also try to use the Android phone APP to test it because we have done an update to the iPhone APP.

Hi,

Thank you for verifying the firmware versions of the buttons in my possession. I agree that the problem is with your button and/or the App. I am highly sceptical that the issue is with the wifi network as I have tried the 3 networks that are available to me and none have worked.

I’m afraid that a hot spot is not an option that we can pursue as it will not be possible in the field. If you think it will help you to debug the defects in your product, I might be able to arrange something in my lab. But I think my assessment (above) will hold.

I do not have an Android phone with which to repeat these tests. Can you send me a signed link to the prior iOS version of the application? Or, as I requested above, can you provide access to the tools that will allow me to connect directly to the device.

I’m really sorry for the trouble brought to you. Could you please provide the model of the router you used? We’d like to be able to reproduce the situation on your side and settle it. @Guy_Bisson

Hi,

See below. However, what are we to do about the two corporate networks that we could not connect to? I don’t have access to their configurations…

Router 1: “success”:true,“data”:{“hardware_version”:“RE200 v2.0”,“multi_progressbar”:“no”,“totaltime”:80,“is_default”:false,“model”:“RE200”,“region”:“US”,“country”:“5553”,“sid”:“5553”,“firmware_version”:“1.1.8 Build 20181113 Rel. 36494”}}

   <LANDeviceNumberOfEntries>1</LANDeviceNumberOfEntries>
<WANDeviceNumberOfEntries>2</WANDeviceNumberOfEntries>
<DeviceInfo>
  <X_CLEARACCESS_COM_Origin>TekSavvy</X_CLEARACCESS_COM_Origin>
  <ModelName>SR505N</ModelName>
  <FirstUseDate>2016-06-03T08:52:43+00:00</FirstUseDate>
  <X_SMARTRG_COM_StingerMode>TRUE</X_SMARTRG_COM_StingerMode>
  <VendorConfigFileNumberOfEntries>0</VendorConfigFileNumberOfEntries>
</DeviceInfo>
<X_BROADCOM_COM_SyslogCfg>
  <Status>Enabled</Status>
</X_BROADCOM_COM_SyslogCfg>
<X_SMARTRG_COM_UserAccessControl instance="1">
  <CustomUserName>guyrbisson</CustomUserName>
  <CustomUserPassword>????==</CustomUserPassword>
  <CustomUserPasswordHash>????=</CustomUserPasswordHash>
  <DeviceInfoEnbl>111111</DeviceInfoEnbl>
  <WirelessEnbl>111111</WirelessEnbl>
  <AdvancedSetupEnbl>11111111111111111111</AdvancedSetupEnbl>
  <DiagnosticsEnbl>1111</DiagnosticsEnbl>
  <Management>111111111</Management>
  <SupportTools>11</SupportTools>
</X_SMARTRG_COM_UserAccessControl>
<X_SMARTRG_COM_UserAccessControl nextInstance="2" ></X_SMARTRG_COM_UserAccessControl>
<X_BROADCOM_COM_AppCfg>
  <HttpdCfg>
    <NetworkAccess>LAN&#32;or&#32;WAN</NetworkAccess>
    <X_SMARTRG_COM_WANport>18080</X_SMARTRG_COM_WANport>
    <EnableHTTPS>TRUE</EnableHTTPS>
  </HttpdCfg>
  <SshdCfg>
    <NetworkAccess>LAN</NetworkAccess>
  </SshdCfg>
  <SnmpdCfg>
    <NetworkAccess>LAN</NetworkAccess>
  </SnmpdCfg>
  <FtpdCfg>
    <NetworkAccess>LAN</NetworkAccess>
  </FtpdCfg>
</X_BROADCOM_COM_AppCfg>
<X_BROADCOM_COM_EthernetSwitch>
  <NumberOfVirtualPorts>4</NumberOfVirtualPorts>
  <EnableVirtualPorts>TRUE</EnableVirtualPorts>
  <IfName>(null)</IfName>
</X_BROADCOM_COM_EthernetSwitch>
<ManagementServer>
  <URL>http://acs.clearaccess.com</URL>
  <LastConnectedURL>http://acs.clearaccess.com</LastConnectedURL>
  <Username>(null)</Username>
  <Password>(null)</Password>
  <PeriodicInformEnable>TRUE</PeriodicInformEnable>
  <PeriodicInformInterval>3600</PeriodicInformInterval>
  <PeriodicInformTime>1970-01-01T00:13:23+00:00</PeriodicInformTime>
  <ConnectionRequestURL notification="2">http://45.72.155.205:30005/</ConnectionRequestURL>
  <ManageableDevice nextInstance="5" ></ManageableDevice>
</ManagementServer>
<Time>
  <Enable>TRUE</Enable>
  <NTPServer1>ca.pool.ntp.org</NTPServer1>
  <NTPServer3>time.nist.gov</NTPServer3>
  <LocalTimeZone>-05:00</LocalTimeZone>
  <LocalTimeZoneName>XXX&#32;5YYY,M3.2.0/02:00:00,M11.1.0/02:00:00</LocalTimeZoneName>
  <DaylightSavingsStart>1970-01-01T00:08:04+00:00</DaylightSavingsStart>
  <DaylightSavingsEnd>1970-01-01T00:08:04+00:00</DaylightSavingsEnd>
</Time>
0 1 DHPL Production Teksavvy WPAand11i 1 104-bit None None TKIPandAESEncryption PSKAuthentication TKIPandAESEncryption PSKAuthentication 54 NOS TRUE NOS CA NOS NOS FALSE FALSE FALSE FALSE 128 FALSE FALSE FALSE 128 FALSE FALSE FALSE 128 DHPL Production wl0 SmartRGWireless 14CDA29394034C4920925559E8ACCF (null) (null) (null) <KI*7ujmNHY^5tgbVFR$3edcXSW@1qaz <KI*7ujmNHY^5tgbVFR$3edcXSW@1qaz 7BEB8ACBD724617307A8696BB8ABDBE9627F1DDF7BF9B5F5A4D7ACC70C38C1A3 CA n 22 128 3 6.30.163.23.cpe4.12L08.1 1 1 1 1 -1 0 DHPL Production 00:23:6A:EE:F7:C7 <KI*7ujmNHY^5tgbVFR$3edcXSW@1qaz tkip+aes psk psk2 128 (null) (null) (null) (null) SmartRGWireless (null) (null) (null) Guest wl0.1 62:23:6a:ee:f7:c4 (null) tkip+aes 0 128 1 (null) (null) (null) (null) (null) (null) (null) (null) 2 Guest1 wl0.2 62:23:6a:ee:f7:c5 (null) tkip+aes 0 128 1 (null) (null) (null) (null) (null) (null) (null) (null) 3 Guest2 wl0.3 62:23:6a:ee:f7:c6 (null) tkip+aes 0 128 1 (null) (null) (null) (null) (null) (null) (null) (null)

This is the data from the 2nd Router that I’ve tried.

Hi @Guy_Bisson
This feels like a calibration problem. You can set a wifi SSID: TE_TEST PSW: 123456789. This is the information on the router settings we used for testing. If it is connected, please try to see if it can update an OTA. By the way, when did you buy the button?

Hi, we have the same issue, iOS app could not save the wifi info into the Button, the button on iOS app did not respond and in consequence, it could not save the wifi info.

We are trying this device for a project, but this project already use a real AWS Button from Amazon, but it seems that this button was deprecated, so we need to test and see if this device can helps us to replace the original AWS.

Can you help us pleas,

By the way the iOS APP Wass downdownloade yesterday (30/Nov/2020) so I think is updated.

Thanks

I’m am seeing the same issue. Using the iOS AWS IoT 1-Click app (version 1.4.4) on iOS 14.3, I could not claim a button or configure WiFi.

Not sure if it helps in debugging, but I saw a device named “IoTButton - XXXXXX” in Bluetooth settings. It did not display in the 1-Click app despite multiple attempts.

Hello, I have the same problem, I was not able to claim the button or configure the wifi, when I choose the wifi network and put the password and al click “Confirm” nothing happens.

My Environment:

  1. Seed IoT Button for AWS
  2. iOS 14.3
  3. AWS IoT 1-Click app v1.4.4
  4. AWS Region; US West (Oregon)

had this same issue, failed 5 times. Then pulling out the battery and plugging in with USB C while doing the steps solved it for me. No idea why, just trying to help everyone

Seeing the same thing. Just bought the SEEED IOT BUTTON FOR AWS and downloaded the AWS IoT 1-Click app (v1.4.4.0). After providing my Wi-Fi information, the screen gets stuck at “Configuration: In progress”. The button showed up briefly at one point in Bluetooth; but it doesn’t seem to ever show up again. The Blue LED (which was blinking) eventually seems to time out and just stops flashing. Would really like to get this all working. Maybe I’ll try a different phone and my iPad…but not having much success at this point.

Update: So, I can put the button into Bluetooth mode and my Laptop (Windows 10) can see it and I can add it as a device. However, I’m not seeing that button communicate with either of my iPhones (I have an 11 and an 8 Plus…both on the latest Apple iOS). Will continue to plow ahead and see if I can get this thing to work.

Hi. Anybody solved this?
I also just got on of the 1-click Seed AWS buttons. I have an iPHONE and iPAd and put the app but it all gets stuck with the Wifi. I put the Wifi name and password click Connect and then nothing happens.
So the button is not connected to the Wifi so can not connect to AWS to get claimed.
I tried by doing hotspot with my phone and use the iPad. Same thing.
Its really bad