Aux connector info

Is there any information anywhere on the AUX 3.5mm audio port jack? There’s nothing in the User Manual. If I plug in a headset, I only get sound on the left. Is this also a microphone jack? I’m using Linux Mint 20. I tested the sound by using the Sound Settings -> Test panel sound applet. If I use the HDMI port, left and right work. I hope the boards not defective or the jack is bad because SEED support sucks and they won’t replace the board for any reason. Please don’t expect me to take a video or a photo of the Odyssey and email it to you - there are no moving parts. I was hoping to use the Odyssey as a SDR HAM radio and that’s why I need the headphones to work.

Jerry, AC9NM

Hi @jponko

Sorry for the issue caused, may i ask for an screenshot of the settings and testing enviorments? We tested on out ubuntu and it’s okay, so trying to recreate your set up.

I tried the very same Ubuntu v20.04 as you on a bootable flash drive. Only the left side of the headphones work. Did you actually try a headphone or are you just saying it’s ok because it shows the output device is headphones - built-in audio. What type of headphones are you using?

Plug in an actual headset and click on the test button as shown in your screen capture and actually test if it works.

Jerry, AC9NM

My environment is a 24" HP HDMI monitor and a Minibox wireless USB keyboard/trackpad on the Odyssey-x86. I have about 5 headsets, of which none produce sound on the right side when used on the Odyssey-x86.
Specifically, here is one brand I’ve tried - Ovleng X7 PC Gaming Headset.

1 Like

By the way, you didn’t answer any of my questions about the audio jack. How about a schematic of the Odyssey-x86?

Also. if you’re trying to recreate my setup exactly, why didn’t you use Linux Mint 20? It’s based on Ubuntu 20.04 and you could have run it off of a flash drive without installing it to a SSD. For your information since you probably didn’t check to see what I purchased, my Odyssey-x86 came in the blue case with the fan and a 128GB M2 SSD drive, So now you should be able to reproduce my system exactly.

Jerry, AC9NM

Okay will have the same set-up as you :slight_smile: let me get back to you

Hi @jponko

I have the same environment and seems working fine?

What exactly was the video supposed to prove? I didn’t see you click on “Front Right” and I didn’t hear anything. Are you trying to say yours works and mine doesn’t. I could send you a video of mine not working and what would that prove? It’s already been established my board is defective. Does SEEED have any quality control procedures to test their boards?

By the way. you never answered my previous questions.

Jerry, AC9NM

Sorry for the issues caused and will let the after-sales team contact you for this issue.

Best Regards,

Will also test with headphones again (instead of earphones) to avoid any errors.

Same issue here. Tested under Elementary OS Hera, Fedora 32 and Windows 10 2004.
On all 3 OSs, only the left hand headphone speaker works. Clicking on the right channel produces no sound.
Also confirmed using 2 different sets of headphones/earbuds.

UEFI v. SD-BS-CJ41G-M-101-G

As I posted elsewhere I get no sound at all in Ubuntu 20.04 with a pair of speakers plugged in.

It’s been almost 30 days. Any progress on this or am I to assume the audio out jack just doesn’t work? Is it an engineering blunder? Does anybody at SEEED knows the answer?

Hi @jponko
Just contact with, we will help you return the X86.

Exactly the same issue here.
See my reply on this topic here:

Same issue here with my new Odyssey Blue bought from a reseller in UK. I have contacted support.

I now think that the aux connector works. Looks like that the issue is that the headphone’s jack can be pushed too far inside the connector and that cause the audio channel issue. If instead the jack is not fully pushed in then both channels work.
Can someone confirm?

PS: Still Seeedstudio has not confirmed if the aux is TRS audio+ mic or just audio, Seeedstudio can you please confirm?

I decided rather than battling this connector to just get a super-cheap USB audio adapter which has completely solved the problem.

Could you try to plug the speakers without pushing them fully in - just 1 or mm; if you push the plug in gently you will feel when the sounds starts on both channels.


No improvement with slightly pulling the audio plug. I’ll just stick with the usb-c audio dongle. Works fine and I already had it. I mean it’s a controller in my workshop, so not like audio is a critical feature (I mostly only need it for YouTube videos when the equipment needs tweaking)