Arduino IDE cant upload sketch because can't find the Seeeduino XIAO on the PORT

I’m working on a small LED sign and I decided to use one of the XIAO microcontrollers that I have, the problem is that I have only once been able to upload the sketch, it doesn’t matter what I do the Arduino IDE keeps showing this error when uploading the sketch:

Sketch uses 40052 bytes (15%) of program storage space. Maximum is 262144 bytes.
No device found on COM4
An error occurred while uploading the sketch

I tried resetting the board, uninstalling the drivers and it is not working at all… I have programed Arduino UNO, and Nano boards (original and clones) without a problem always, but the XIAO is just too much of a pain to get it working (I tried two different microcontrollers and the same happens)!!!

Can someone point me on the right direction to understand and address what can be creating the problem?

sounds like bootloader may have bricked

if so you can look at this post and others on the forum
i was able to unbrick using this procedure and maybe another its been a while ago
i used two XIAO expansion boards to make the connection and reset bootloader without using a raspberry pi…

hope this helps

Hi there,
You can try plugging into another computer or laptop does it recognize it. It may be that it’s bricked but if it’s never been programmed then could be a windows driver issue also. Sketch size is fine btw, I have used many and only ever had one that needed unbricked because I accidently removed the softdevice with nrf desktop programmer app. I used the same to re-write the correct Xiao.img and restored it to a working unit.
GL :slight_smile:

It’s not bricked because one of 20 attempts works, I have another 3 XIAO and 2 of that 3 are exactly the same pain to get them working…

I was able to upload 3 times my sketch and I give up…

Probably it is how windows detect and handle the connection with the XIAO and at the end it’s truly a shame because I know that I’m not the only one having problems with the bootloader on the seeeduino.

I can not blame on windows because the drivers that control every other device plugged in the USB ports work as intended, can not blame on the PC running the OS because it is handling any hardware plugged in as it should be and neither can blame on the Arduino IDE because there aren’t any problems uploading sketches to original Arduino hardware or cheap clones so the finger has to be pointed to Seeed.

I already rewired the PCB to accommodate a Arduino nano clone so I will return the seeeduino to the box and put it on the drawer of parts and maybe try again on the future with another project.

Just a few other ideas

I have noticed when the XIAO mounts it will switch lets say from
com 7 to com 8 and a window will pop up to mount the device as a external file storage
presumably like mbed file drag and drop
it this window question is ignored it will prevent the com port recognizition

this is agrivationg and you have to make sure the correct port is selected in IDE for upload or serial monitor

also it helps if the board is properly installed in the IDE before connecting
if not it somehow has an effect on the IDE recognizing the board and port


It seems like you’re experiencing difficulties uploading sketches to your Seeeduino XIAO microcontroller using the Arduino IDE. Here are a few troubleshooting steps you can try to address the issue:

  1. Ensure the correct board is selected: Double-check that you have selected the correct board in the Arduino IDE. In this case, you should choose “Seeeduino XIAO” from the “Tools” > “Board” menu.
  2. Verify the port selection: Make sure you have selected the correct serial port for your XIAO board. Go to the “Tools” > “Port” menu and check if the COM port listed corresponds to the XIAO board. If the port is not listed or grayed out, it may indicate a driver issue.
  3. Install the CH340 driver (if necessary): The Seeeduino XIAO board often uses the CH340 USB-to-serial converter chip. If you haven’t installed the driver for this chip, you may encounter issues. Visit the Seeed Studio website or search online for the CH340 driver and download/install it on your computer.
  4. Try a different USB cable and port: Sometimes, a faulty USB cable or port can cause upload issues. Try using a different USB cable and connect the XIAO board to a different USB port on your computer.
  5. Press the reset button: Before uploading the sketch, press the reset button on the XIAO board. This action resets the board and puts it in the bootloader mode, allowing the sketch to be uploaded.
  6. Reinstall the bootloader: If none of the above steps work, you may need to reinstall the bootloader on your XIAO board. Refer to the Seeed Studio documentation or forums for instructions on how to perform a bootloader reinstall. sofa recliner

If you have tried all these steps and are still unable to upload sketches to your Seeeduino XIAO, it may be helpful to reach out to the Seeed Studio support team or consult the Seeed Studio forums for further assistance. They can provide more specific guidance and troubleshooting steps for the XIAO board.

1 Like