After amending the /boot/extlinux/extlinux.conf I can't boot

Hi there,

A real noob question here - I was following the article from SeeedStudio to get my reComputer J1010 to boot from an SD card, but I got very mixed up with the process and managed to miss the important step of coping my eMMC disk to a new SD card and then changed the /boot/extlinux/extlinux.conf file to point to the SD card, which works until it doesn’t.

I was getting confused with a number of other articles that mentioned the constraints of the Ubuntu 18 OS and flashing a SD card with a different version.

When I try and boot from the nvidia downloaded image ( Jetson Nano Developer Kit SD Card Image,) it gets as far as GNOME setup and errors.

I have tried a number of other images, but no good.

Clearly I went horribly wrong with the install of the SD card - ideally I would like to reset the eMMC /boot/extlinux/extlinux.conf file to point to the eMMC boot image and not the SD card.

I can boot to $bash, but from there I am lost.

Can anyone suggest a way forward please?

Thank you all in advance.


Hi @tjax .
If you want to move the system to an SD card, please do so as follows:

  1. If you want to move the system to SD card, you need to flash the JetPack OS to reComputer J1010. That is, follow the Wiki below:
  1. After successfully flashing the jetpack to the J1010, open the desktop of the J1010 and enable the SD card by following the steps in the link below.
  1. After successfully completing the second step, you can already enable the onboard SD card function. Next you need to move the system to the SD card, i.e. perform the steps in the link below.

After completing the above four steps, you can move the system to the SD card.

Please note that you cannot use the Jetson Nano image flashed on the Jetson Nano Developer Kit on the J1010. If you want to boot from an SD card on the J1010, you can only follow the steps provided above.

Thank you for this - I basically reimaged the device. I found the SD card reader really slow, so I connected a 200 GB SSD via USB and it flies.

Thank you for your help.


I’m glad to hear that. Congratulations!