A603 Carrier Board for Jetson Orin NX - Flash fails


I have an Nvidia Jetson Orin NX 16Gb and as the carrier board, I have an A603 manufactured by Seeed Studio. I have tried to follow your step-by-step flash guide in https://wiki.seeedstudio.com/reComputer_A603_Flash_System/ but haven’t succeeded in the flashing even after multiple trials. I add the flashing .log file as an attachment to this email. The problem is that in Step 3 the Flashing always stops with the same error:

Error: Could not stat device /dev/nvme0n1 - No such file or directory.

So the SSD in the M.2 slot is not detected. The SSD model is CoreParts NT-256 2242. I ensured that the SSD is not broken by installing it on a desktop computer and checking that it was working correctly. I also tried to flash the system to a USB flash drive but got a similar error:

Error: Could not stat device /dev/sda - No such file or directory.

I have tried the flashing with both JetPack Version 5.1.1 and L4T Version 35.3.1 and with JetPack Version 5.1.2 and L4T Version 35.4.1. I have also tried flashing with both Ubuntu 18.04 and Ubuntu 20.04 as a host computer operating system. I have removed all unnecessary peripherals, such as WiFi, during the flashing process. My USB cable supports data transmission, and I have successfully flashed other Jetson models with Connecttech or Nvidia carrier boards earlier with the same setup, so I assume that there shouldn’t be any technical problems related to the host environment. lsusb gives also the correct output: 0955:7323 NVidia Corp.

Do you have any idea, what could be the reason for this Error during the flashing and how it could be solved?