ReSpeaker Mic Array V2 recording noise

info about ReSpeaker series products

Moderators: lily.li, violet, seth.welday

Post Reply
ningma97
Pre-kindergarten
Pre-kindergarten
Posts: 9
Joined: Thu Sep 06, 2018 8:07 pm

ReSpeaker Mic Array V2 recording noise

Post by ningma97 » Sat May 25, 2019 7:09 am

Hi,

I posted this before but still cannot solve the issue.

I connected the ReSpeaker Mic Array V2 from the bottom pins to a Raspberry Pi 3B+. All works fine but I notice the recording has an audible noise. See the attached spectrogram: the noise is shown as the horizontal lines as multiples of 1kHz.

If I connect the Mic Array via the micro USB port, the situation is slightly better but it seems to depend on the USB cable. In the end I found a very short USB cable and used to connect the mic array via the micro USB port, the noise disappeared.

I need to connect the Mic Array from the bottom as the micro USB port is in the way. Any suggestions, please?

Ning
Attachments
micarray noise.png
micarray noise.png (646.7 KiB) Viewed 590 times

bill.yu
Elementary-5
Elementary-5
Posts: 597
Joined: Mon Apr 02, 2018 11:05 am

Re: ReSpeaker Mic Array V2 recording noise

Post by bill.yu » Thu Jun 13, 2019 4:15 pm

Hi there,

We updated the firmware and you can delete your local one and download the latest one, burn to your xmos. Hope it can solve the issue. thanks.

Code: Select all

sudo apt-get update
sudo pip install pyusb click
git clone https://github.com/respeaker/usb_4_mic_array.git
cd usb_4_mic_array
sudo python dfu.py --download 6_channels_firmware.bin  # The 6 channels version 

# if you want to use 1 channel,then the command should be like:

sudo python dfu.py --download 1_channel_firmware.bin

Post Reply